12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
- ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages ncdu)
- #:use-module (gnu packages)
- #:use-module (gnu packages ncurses)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
- (define-public ncdu
- (package
- (name "ncdu")
- (version "1.16")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://dev.yorhel.nl/download/ncdu-"
- version ".tar.gz"))
- (sha256
- (base32
- "1m0gk09jaz114piidiw8fkg0id5l6nhz1cg5nlaf1yl3l595g49b"))))
- (build-system gnu-build-system)
- (inputs `(("ncurses" ,ncurses)))
- (synopsis "Ncurses-based disk usage analyzer")
- (description
- "Ncdu is a disk usage analyzer with an ncurses interface, aimed to be
- run on a remote server where you don't have an entire graphical setup, but have
- to do with a simple SSH connection. ncdu aims to be fast, simple and easy to
- use, and should be able to run in any minimal POSIX-like environment with
- ncurses installed.")
- (license (x11-style
- (string-append "https://g.blicky.net/ncdu.git/plain/COPYING?id=v"
- version)))
- (home-page "https://dev.yorhel.nl/ncdu")))
|