autogen.scm 3.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages autogen)
  22. #:use-module (guix packages)
  23. #:use-module (guix licenses)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages perl)
  28. #:use-module (gnu packages pkg-config)
  29. #:use-module (gnu packages base)
  30. #:use-module (gnu packages guile))
  31. (define-public autogen
  32. (package
  33. (name "autogen")
  34. (version "5.18.16")
  35. (source
  36. (origin
  37. (method url-fetch)
  38. (uri (string-append "mirror://gnu/autogen/rel" version
  39. "/autogen-" version ".tar.xz"))
  40. (sha256
  41. (base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))
  42. (modules '((guix build utils)))
  43. (snippet
  44. ;; Address '-Werror=format-overflow' error.
  45. '(substitute* "getdefs/getdefs.c"
  46. (("def_bf\\[[[:space:]]*MAXNAMELEN[[:space:]]*\\]")
  47. "def_bf[MAXNAMELEN + 10]")))))
  48. (build-system gnu-build-system)
  49. (native-inputs (list pkg-config which))
  50. (inputs (list guile-2.2 perl)) ; for doc generator mdoc
  51. (arguments
  52. '(#:configure-flags
  53. ;; XXX Needed to build 5.18.16. ./configure fails without it:
  54. ;; “Something went wrong bootstrapping makefile fragments for
  55. ;; automatic dependency tracking. Try re-running configure with […]”
  56. (list "--disable-dependency-tracking")
  57. ;; XXX: Parallel tests may cause an indefinite hang with GNU Make 4.3.
  58. #:parallel-tests? #f
  59. #:phases
  60. (modify-phases %standard-phases
  61. (add-before 'patch-source-shebangs 'patch-test-scripts
  62. (lambda _
  63. (let ((sh (which "sh")))
  64. (substitute*
  65. (append (find-files "agen5/test" "\\.test$")
  66. (find-files "autoopts/test" "\\.(test|in)$"))
  67. (("/bin/sh") sh))
  68. #t))))))
  69. (home-page "https://www.gnu.org/software/autogen/")
  70. (synopsis "Automated program generator")
  71. (description
  72. "AutoGen is a program to ease the maintenance of programs that contain
  73. large amounts of repetitive text. It automates the construction of these
  74. sections of the code, simplifying the task of keeping the text in sync. It
  75. also includes an add-on package called AutoOpts, which is specialized for the
  76. maintenance and documentation of program options.")
  77. (license gpl3+)))