12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182 |
- (define-module (gnu packages autogen)
- #:use-module (guix packages)
- #:use-module (guix licenses)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages base)
- #:use-module (gnu packages guile))
- (define-public autogen
- (package
- (name "autogen")
- (version "5.18.16")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/autogen/rel" version
- "/autogen-" version ".tar.xz"))
- (sha256
- (base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))
- (modules '((guix build utils)))
- (snippet
-
- '(substitute* "getdefs/getdefs.c"
- (("def_bf\\[[[:space:]]*MAXNAMELEN[[:space:]]*\\]")
- "def_bf[MAXNAMELEN + 10]")))))
- (build-system gnu-build-system)
- (native-inputs (list pkg-config which))
- (inputs (list guile-2.2 perl))
- (arguments
- '(#:configure-flags
-
-
-
- (list "--disable-dependency-tracking")
-
- #:parallel-tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-before 'patch-source-shebangs 'patch-test-scripts
- (lambda _
- (let ((sh (which "sh")))
- (substitute*
- (append (find-files "agen5/test" "\\.test$")
- (find-files "autoopts/test" "\\.(test|in)$"))
- (("/bin/sh") sh))
- #t))))))
- (home-page "https://www.gnu.org/software/autogen/")
- (synopsis "Automated program generator")
- (description
- "AutoGen is a program to ease the maintenance of programs that contain
- large amounts of repetitive text. It automates the construction of these
- sections of the code, simplifying the task of keeping the text in sync. It
- also includes an add-on package called AutoOpts, which is specialized for the
- maintenance and documentation of program options.")
- (license gpl3+)))
|