meme-suite.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133
  1. #!/bin/bash
  2. # Slackware build script for meme-suite
  3. # Copyright 2017-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=meme-suite
  24. VERSION=${VERSION:-5.3.3}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCNAM=meme
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf ${SRCNAM}-${VERSION}
  64. tar xvf $CWD/${SRCNAM}-${VERSION}.tar.gz
  65. cd ${SRCNAM}-${VERSION}
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. # Change name from "meme" to "meme-suite"
  73. sed -i "s:PACKAGE_NAME='meme':PACKAGE_NAME='meme-suite':" configure
  74. # Do not append the package version to folder names
  75. find . -name "Makefile.*" -exec \
  76. sed -i 's:${PACKAGE_NAME}-${PACKAGE_VERSION}:${PACKAGE_NAME}:g' {} \;
  77. # Sometimes the brackets are not curly
  78. find . -name "Makefile.*" -exec \
  79. sed -i 's:$(PACKAGE_NAME)-${PACKAGE_VERSION}:$(PACKAGE_NAME):g' {} \;
  80. # Documentation should go to docdir not datadir
  81. sed -i 's:${datadir}/${PACKAGE_NAME}:${docdir}:g' doc/Makefile.*
  82. # Make empty folders for the databases
  83. mkdir -p $PKG/var/lib/$PRGNAM/{fasta_databases,gomo_databases,motif_databases,tgene_databases}
  84. ./configure \
  85. --prefix=/usr \
  86. --libdir=/usr/lib${LIBDIRSUFFIX} \
  87. --docdir=/usr/doc/$PRGNAM-$VERSION \
  88. --with-url="http://meme-suite.org" \
  89. --datarootdir=/usr/share \
  90. --libexecdir=/usr/libexec \
  91. --localstatedir=/var \
  92. --mandir=/usr/man \
  93. --with-db=/var/lib/$PRGNAM \
  94. --with-temp=/tmp
  95. make CFLAGS="$SLKCFLAGS -std=gnu89"
  96. make install DESTDIR=$PKG
  97. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  98. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  99. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  100. cp -a \
  101. AUTHORS COPYING INSTALL README \
  102. $PKG/usr/doc/$PRGNAM-$VERSION
  103. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  104. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  105. cat $CWD/README.TESTS > $PKG/usr/doc/$PRGNAM-$VERSION/README.TESTS
  106. cat $CWD/README.DATABASES > $PKG/usr/doc/$PRGNAM-$VERSION/README.DATABASES
  107. mkdir -p $PKG/install
  108. cat $CWD/slack-desc > $PKG/install/slack-desc
  109. cd $PKG
  110. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE