xcircuit.SlackBuild 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. #!/bin/bash
  2. # Slackware build script for grace
  3. # Written by B. Jogai <jogaib {at} comcast [dot] net>
  4. cd $(dirname $0) ; CWD=$(pwd)
  5. PRGNAM=xcircuit
  6. VERSION=${VERSION:-3.7.54}
  7. BUILD=${BUILD:-1}
  8. TAG=${TAG:-"_SBo"}
  9. PKGTYPE=${PKGTYPE:-tgz}
  10. if [ -z "$ARCH" ]; then
  11. case "$( uname -m )" in
  12. i?86) ARCH=i486 ;;
  13. arm*) ARCH=arm ;;
  14. *) ARCH=$( uname -m ) ;;
  15. esac
  16. fi
  17. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  18. # the name of the created package would be, and then exit. This information
  19. # could be useful to other scripts.
  20. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  21. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  22. exit 0
  23. fi
  24. TMP=${TMP:-/tmp/SBo}
  25. PKG=$TMP/package-$PRGNAM
  26. OUTPUT=${OUTPUT:-/tmp}
  27. if [ "$ARCH" = "i486" ]; then
  28. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  29. LIBDIRSUFFIX=""
  30. elif [ "$ARCH" = "i686" ]; then
  31. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  32. LIBDIRSUFFIX=""
  33. elif [ "$ARCH" = "x86_64" ]; then
  34. SLKCFLAGS="-O2 -fPIC"
  35. LIBDIRSUFFIX="64"
  36. else
  37. SLKCFLAGS="-O2"
  38. LIBDIRSUFFIX=""
  39. fi
  40. set -e
  41. rm -rf $PKG
  42. mkdir -p $TMP $PKG $OUTPUT
  43. cd $TMP
  44. rm -rf $PRGNAM-$VERSION $PRGNAM
  45. tar xvf $CWD/$PRGNAM-$VERSION.tgz
  46. cd $PRGNAM-$VERSION
  47. chown -R root:root .
  48. find -L . \
  49. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  50. -exec chmod 755 {} \; -o \
  51. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  52. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  53. CFLAGS="$SLKCFLAGS" \
  54. ./configure \
  55. --prefix=/usr \
  56. --bindir=/usr/bin \
  57. --libdir=/usr/lib${LIBDIRSUFFIX} \
  58. --mandir=/usr/man \
  59. --with-x \
  60. --with-ngspice \
  61. --with-tcl=/usr/lib${LIBDIRSUFFIX} \
  62. --build=$ARCH-slackware-linux \
  63. make
  64. make DESTDIR=$PKG install
  65. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  66. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  67. # Add desktop menu entries
  68. mkdir -p $PKG/usr/share/{applications,pixmaps}
  69. cat $CWD/xcircuit.png > $PKG/usr/share/pixmaps/xcircuit.png
  70. cat $CWD/xcircuit.desktop > $PKG/usr/share/applications/xcircuit.desktop
  71. # Copy the man pages from the lib to the man directory.
  72. # Don't move it in case the program needs it there for some reason.
  73. rm -rf $PKG/usr/man
  74. mkdir -p $PKG/usr/man/man1
  75. cp $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM-3.7/man/*.1 $PKG/usr/man/man1
  76. find $PKG/usr/man -type f -exec gzip -9 {} \;
  77. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  78. cp -a CHANGES README* TODO VERSION examples $PKG/usr/doc/$PRGNAM-$VERSION
  79. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  80. find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
  81. mkdir -p $PKG/install
  82. cat $CWD/slack-desc > $PKG/install/slack-desc
  83. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  84. cd $PKG
  85. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE