123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103 |
- #!/bin/bash
- # Slackware build script for grace
- # Written by B. Jogai <jogaib {at} comcast [dot] net>
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=xcircuit
- VERSION=${VERSION:-3.7.54}
- BUILD=${BUILD:-1}
- TAG=${TAG:-"_SBo"}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION $PRGNAM
- tar xvf $CWD/$PRGNAM-$VERSION.tgz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- CFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --bindir=/usr/bin \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --mandir=/usr/man \
- --with-x \
- --with-ngspice \
- --with-tcl=/usr/lib${LIBDIRSUFFIX} \
- --build=$ARCH-slackware-linux \
- make
- make DESTDIR=$PKG install
- find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- # Add desktop menu entries
- mkdir -p $PKG/usr/share/{applications,pixmaps}
- cat $CWD/xcircuit.png > $PKG/usr/share/pixmaps/xcircuit.png
- cat $CWD/xcircuit.desktop > $PKG/usr/share/applications/xcircuit.desktop
- # Copy the man pages from the lib to the man directory.
- # Don't move it in case the program needs it there for some reason.
- rm -rf $PKG/usr/man
- mkdir -p $PKG/usr/man/man1
- cp $PKG/usr/lib$LIBDIRSUFFIX/$PRGNAM-3.7/man/*.1 $PKG/usr/man/man1
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a CHANGES README* TODO VERSION examples $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|