cufflinks.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100
  1. #!/bin/bash
  2. # Slackware build script for cufflinks
  3. # Copyright 2013-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # For Slackware 15.0 I switched to just repackaging the upstream binaries.
  23. # When I find a patch that fixes the build against boost and a bunch of other
  24. # fixes, I will revert back to source build. Let's have ot like this for now.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM=cufflinks
  27. VERSION=${VERSION:-2.2.1}
  28. BUILD=${BUILD:-2}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. ARCH="$( uname -m )"
  33. fi
  34. if [ "$ARCH" != "x86_64" ]; then
  35. printf "\n\n$ARCH is not supported... \n" >&2
  36. exit 1
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. set -e
  49. rm -rf $PKG
  50. mkdir -p $TMP $PKG $OUTPUT
  51. cd $TMP
  52. rm -rf $PRGNAM-${VERSION}.Linux_${ARCH}
  53. tar xvf $CWD/$PRGNAM-${VERSION}.Linux_${ARCH}.tar.gz
  54. cd $PRGNAM-${VERSION}.Linux_${ARCH}
  55. chown -R root:root .
  56. find -L . \
  57. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  58. -o -perm 511 \) -exec chmod 755 {} \; -o \
  59. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  60. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  61. # Just in case...
  62. sed -i "s:python:python2:" cuffmerge
  63. install -D -m755 cuffcompare $PKG/usr/bin/cuffcompare
  64. install -D -m755 cuffdiff $PKG/usr/bin/cuffdiff
  65. install -D -m755 cufflinks $PKG/usr/bin/cufflinks
  66. install -D -m755 cuffmerge $PKG/usr/bin/cuffmerge
  67. install -D -m755 cuffnorm $PKG/usr/bin/cuffnorm
  68. install -D -m755 cuffquant $PKG/usr/bin/cuffquant
  69. install -D -m755 gffread $PKG/usr/bin/gffread
  70. install -D -m755 gtf_to_sam $PKG/usr/bin/gtf_to_sam
  71. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  72. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  73. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  74. cp -a \
  75. AUTHORS LICENSE README \
  76. $PKG/usr/doc/$PRGNAM-$VERSION
  77. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  78. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  79. mkdir -p $PKG/install
  80. cat $CWD/slack-desc > $PKG/install/slack-desc
  81. cd $PKG
  82. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE