123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100 |
- #!/bin/bash
- # Slackware build script for cufflinks
- # Copyright 2013-2021 Petar Petrov slackalaxy@gmail.com
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # For Slackware 15.0 I switched to just repackaging the upstream binaries.
- # When I find a patch that fixes the build against boost and a bunch of other
- # fixes, I will revert back to source build. Let's have ot like this for now.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=cufflinks
- VERSION=${VERSION:-2.2.1}
- BUILD=${BUILD:-2}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- ARCH="$( uname -m )"
- fi
- if [ "$ARCH" != "x86_64" ]; then
- printf "\n\n$ARCH is not supported... \n" >&2
- exit 1
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-${VERSION}.Linux_${ARCH}
- tar xvf $CWD/$PRGNAM-${VERSION}.Linux_${ARCH}.tar.gz
- cd $PRGNAM-${VERSION}.Linux_${ARCH}
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Just in case...
- sed -i "s:python:python2:" cuffmerge
- install -D -m755 cuffcompare $PKG/usr/bin/cuffcompare
- install -D -m755 cuffdiff $PKG/usr/bin/cuffdiff
- install -D -m755 cufflinks $PKG/usr/bin/cufflinks
- install -D -m755 cuffmerge $PKG/usr/bin/cuffmerge
- install -D -m755 cuffnorm $PKG/usr/bin/cuffnorm
- install -D -m755 cuffquant $PKG/usr/bin/cuffquant
- install -D -m755 gffread $PKG/usr/bin/gffread
- install -D -m755 gtf_to_sam $PKG/usr/bin/gtf_to_sam
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a \
- AUTHORS LICENSE README \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|