dmd.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. #!/bin/bash
  2. # Slackware build script for DMD
  3. # Copyright 2016-2019 Eugene Wissner, Dachau, Germany
  4. # All rights reserved.
  5. #
  6. # Redistribution and use in source and binary forms, with or without
  7. # modification, are permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of source code must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
  13. # EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
  14. # WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
  15. # DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
  16. # DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
  17. # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
  18. # LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
  19. # ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  20. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
  21. # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=dmd
  24. VERSION=${VERSION:-2.100.2}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "x86_64" ]; then
  46. LIBDIRSUFFIX="64"
  47. ARCHSUFFIX="64"
  48. else
  49. LIBDIRSUFFIX=""
  50. ARCHSUFFIX="32"
  51. fi
  52. set -e
  53. rm -rf $PKG
  54. mkdir -p $TMP $PKG $OUTPUT
  55. cd $TMP
  56. rm -rf $PRGNAM${VERSION%%.*}
  57. tar xvf $CWD/$PRGNAM.$VERSION.linux.tar.xz
  58. cd $PRGNAM${VERSION%%.*}
  59. chown -R root:root .
  60. find -L . \
  61. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  62. -o -perm 511 \) -exec chmod 755 {} \; -o \
  63. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  64. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  65. mkdir $PKG/etc
  66. sed -e "s|%@P%/../../src/phobos -I%@P%/../../src/druntime/import|/usr/include/dmd|g" \
  67. -e "s|%@P%/../lib32|/usr/lib|" \
  68. -e "s|%@P%/../lib64|/usr/lib64|" \
  69. linux/bin${ARCHSUFFIX}/dmd.conf > $PKG/etc/dmd.conf
  70. mkdir -p $PKG/usr/bin
  71. mv linux/bin${ARCHSUFFIX}/dmd $PKG/usr/bin
  72. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX} $PKG/usr/include/dmd
  73. # Runtime.
  74. mv src/druntime/src/{core,etc,object.d} $PKG/usr/include/dmd
  75. find $PKG/usr/include/dmd -name "*.S" -print0 | xargs -0 rm
  76. # Phobos.
  77. mv linux/lib${ARCHSUFFIX}/libphobos2.* $PKG/usr/lib${LIBDIRSUFFIX}
  78. mv src/phobos/std $PKG/usr/include/dmd
  79. mv src/phobos/etc/c $PKG/usr/include/dmd/etc
  80. rm -r $PKG/usr/include/dmd/etc/c/zlib
  81. # DMD.
  82. mv src/dmd/dmd $PKG/usr/include/dmd
  83. # Remove C/C++ sources.
  84. find $PKG/usr/include/dmd \( -name "*.c" -or -name "*.h" \) -print0 | xargs -0 rm
  85. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  86. mv html/d/* $PKG/usr/doc/$PRGNAM-$VERSION
  87. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  88. mkdir -p $PKG/install
  89. cat $CWD/slack-desc > $PKG/install/slack-desc
  90. cd $PKG
  91. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE