123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113 |
- #!/bin/bash
- # Slackware build script for DMD
- # Copyright 2016-2019 Eugene Wissner, Dachau, Germany
- # All rights reserved.
- #
- # Redistribution and use in source and binary forms, with or without
- # modification, are permitted provided that the following conditions are met:
- #
- # 1. Redistributions of source code must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
- # EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
- # WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
- # DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
- # DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
- # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
- # LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
- # ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
- # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=dmd
- VERSION=${VERSION:-2.100.2}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
- ARCHSUFFIX="64"
- else
- LIBDIRSUFFIX=""
- ARCHSUFFIX="32"
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM${VERSION%%.*}
- tar xvf $CWD/$PRGNAM.$VERSION.linux.tar.xz
- cd $PRGNAM${VERSION%%.*}
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- mkdir $PKG/etc
- sed -e "s|%@P%/../../src/phobos -I%@P%/../../src/druntime/import|/usr/include/dmd|g" \
- -e "s|%@P%/../lib32|/usr/lib|" \
- -e "s|%@P%/../lib64|/usr/lib64|" \
- linux/bin${ARCHSUFFIX}/dmd.conf > $PKG/etc/dmd.conf
- mkdir -p $PKG/usr/bin
- mv linux/bin${ARCHSUFFIX}/dmd $PKG/usr/bin
- mkdir -p $PKG/usr/lib${LIBDIRSUFFIX} $PKG/usr/include/dmd
- # Runtime.
- mv src/druntime/src/{core,etc,object.d} $PKG/usr/include/dmd
- find $PKG/usr/include/dmd -name "*.S" -print0 | xargs -0 rm
- # Phobos.
- mv linux/lib${ARCHSUFFIX}/libphobos2.* $PKG/usr/lib${LIBDIRSUFFIX}
- mv src/phobos/std $PKG/usr/include/dmd
- mv src/phobos/etc/c $PKG/usr/include/dmd/etc
- rm -r $PKG/usr/include/dmd/etc/c/zlib
- # DMD.
- mv src/dmd/dmd $PKG/usr/include/dmd
- # Remove C/C++ sources.
- find $PKG/usr/include/dmd \( -name "*.c" -or -name "*.h" \) -print0 | xargs -0 rm
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- mv html/d/* $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|