knime.SlackBuild 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. #!/bin/bash
  2. # Slackware build script for knime
  3. # Copyright 2014 Stephen Van Berg USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Stephen Van Berg 2014-4-17
  23. # Updated 2015-07-31 for knime version 2.12.0
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=knime
  26. VERSION=${VERSION:-2.12.0}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. set -e
  48. rm -rf $PKG
  49. mkdir -p $TMP $PKG/opt $OUTPUT
  50. cd $PKG/opt
  51. if [ "$ARCH" = "x86_64" ]; then
  52. tar -xvf $CWD/$PRGNAM\_$VERSION.linux.gtk.$ARCH.tar.gz
  53. elif [ "$ARCH" = "i586" ]; then
  54. tar -xvf $CWD/$PRGNAM\_$VERSION.linux.gtk.x86.tar.gz
  55. else
  56. printf "$ARCH is not supported...\n" ; exit 1
  57. fi
  58. mv $PRGNAM\_$VERSION $PRGNAM # pull out version from target dir
  59. mkdir -p $PKG/usr/bin
  60. chown -R root:root .
  61. find -L . \
  62. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  63. -o -perm 511 \) -exec chmod 755 {} \; -o \
  64. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  65. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  66. install -m755 $CWD/$PRGNAM.wrapper $PKG/usr/bin/$PRGNAM # Put wrapper exec (starts program in homedir) in /usr/bin
  67. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  68. cd $PKG/opt/$PRGNAM
  69. cp -a LICENSE.TXT README.txt quickstart.pdf $PKG/usr/doc/$PRGNAM-$VERSION
  70. mkdir -p $PKG/usr/share/pixmaps $PKG/usr/share/applications
  71. cp -a $PKG/opt/$PRGNAM/icon.xpm $PKG/usr/share/pixmaps/$PRGNAM.xpm
  72. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
  73. mkdir -p $PKG/install
  74. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  75. cat $CWD/slack-desc > $PKG/install/slack-desc
  76. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  77. cd $PKG
  78. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE