123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293 |
- #!/bin/bash
- # Slackware build script for knime
- # Copyright 2014 Stephen Van Berg USA
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # Stephen Van Berg 2014-4-17
- # Updated 2015-07-31 for knime version 2.12.0
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=knime
- VERSION=${VERSION:-2.12.0}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG/opt $OUTPUT
- cd $PKG/opt
- if [ "$ARCH" = "x86_64" ]; then
- tar -xvf $CWD/$PRGNAM\_$VERSION.linux.gtk.$ARCH.tar.gz
- elif [ "$ARCH" = "i586" ]; then
- tar -xvf $CWD/$PRGNAM\_$VERSION.linux.gtk.x86.tar.gz
- else
- printf "$ARCH is not supported...\n" ; exit 1
- fi
- mv $PRGNAM\_$VERSION $PRGNAM # pull out version from target dir
- mkdir -p $PKG/usr/bin
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- install -m755 $CWD/$PRGNAM.wrapper $PKG/usr/bin/$PRGNAM # Put wrapper exec (starts program in homedir) in /usr/bin
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cd $PKG/opt/$PRGNAM
- cp -a LICENSE.TXT README.txt quickstart.pdf $PKG/usr/doc/$PRGNAM-$VERSION
- mkdir -p $PKG/usr/share/pixmaps $PKG/usr/share/applications
- cp -a $PKG/opt/$PRGNAM/icon.xpm $PKG/usr/share/pixmaps/$PRGNAM.xpm
- cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
- mkdir -p $PKG/install
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|