iTest.SlackBuild 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153
  1. #!/bin/bash
  2. # Slackware build script for iTest
  3. # Copyright 2014 R. S. Ananda Murthy, Mysore, India
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=iTest
  24. VERSION=${VERSION:-1.4.2_PREVIEW4}
  25. SRCVER=$(echo $VERSION | tr _ -)
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAM-$VERSION-src
  64. tar xvf $CWD/$PRGNAM-$SRCVER-src.tar.gz
  65. cd $PRGNAM-$SRCVER-src
  66. # Replace-direct-calls-to-constructor
  67. find . -name "*.cpp" -type f -exec sed -i -e 's|QColor::QColor|QColor|g' -e 's|QBrush::QBrush|QBrush|g' -e 's|QDate::QDate|QDate|g' -e 's|QTime::QTime|QTime|g' -e 's|QDateTime::QDateTime|QDateTime|g' -e 's|QIcon::QIcon|QIcon|g' -e 's|QSize::QSize|QSize|g' -e 's|QFont::QFont|QFont|g' {} \;
  68. find . -name "*.h" -type f -exec sed -i -e 's|QColor::QColor|QColor|g' -e 's|QBrush::QBrush|QBrush|g' -e 's|QDate::QDate|QDate|g' -e 's|QTime::QTime|QTime|g' -e 's|QDateTime::QDateTime|QDateTime|g' -e 's|QIcon::QIcon|QIcon|g' -e 's|QSize::QSize|QSize|g' -e 's|QFont::QFont|QFont|g' {} \;
  69. patch -p0 < $CWD/itestserver-session_cpp.diff
  70. chown -R root:root .
  71. find -L . \
  72. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  73. -o -perm 511 \) -exec chmod 755 {} \; -o \
  74. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  75. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  76. . /etc/profile.d/qt4.sh
  77. cd iTestServer
  78. lrelease iTestServer.pro
  79. cd ..
  80. cd iTestClient
  81. lrelease iTestClient.pro
  82. cd ..
  83. qmake -config release
  84. make
  85. #copying files to packaging directory
  86. cd $PKG
  87. mkdir -p $PKG/usr/bin
  88. mkdir -p $PKG/usr/share/{applications,icons/hicolor/48x48/apps}
  89. install -m 755 -p $TMP/$PRGNAM-$SRCVER-src/bin/iTestServer $PKG/usr/bin
  90. #create desktop file for server
  91. cat << "EOF" >$PKG/usr/share/applications/iTestServer.desktop
  92. [Desktop Entry]
  93. Encoding=UTF-8
  94. Name=iTest Server
  95. Exec=iTestServer
  96. Comment=iTest Server
  97. GenericName=iTest Server
  98. Terminal=false
  99. Type=Application
  100. Categories=Education;
  101. Icon=iTestServer
  102. EOF
  103. cp -f $TMP/$PRGNAM-$SRCVER-src/iTestServer/images/itest48.png $PKG/usr/share/icons/hicolor/48x48/apps/iTestServer.png
  104. install -m 755 -p $TMP/$PRGNAM-$SRCVER-src/bin/iTestClient $PKG/usr/bin
  105. #create desktop file
  106. cat << "EOF" >$PKG/usr/share/applications/iTestClient.desktop
  107. [Desktop Entry]
  108. Encoding=UTF-8
  109. Name=iTest Client
  110. Exec=iTestClient
  111. Comment=iTest Client
  112. GenericName=iTest Client
  113. Terminal=false
  114. Type=Application
  115. Categories=Education;
  116. Icon=iTestClient
  117. EOF
  118. cp -f $TMP/$PRGNAM-$SRCVER-src/iTestClient/images/itcl.png $PKG/usr/share/icons/hicolor/48x48/apps/iTestClient.png
  119. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  120. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  121. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  122. cp -a $TMP/$PRGNAM-$SRCVER-src/readme.txt \
  123. $TMP/$PRGNAM-$SRCVER-src/gpl.txt $PKG/usr/doc/$PRGNAM-$VERSION
  124. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  125. mkdir -p $PKG/install
  126. cat $CWD/slack-desc > $PKG/install/slack-desc
  127. cd $PKG
  128. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE