123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153 |
- #!/bin/bash
- # Slackware build script for iTest
- # Copyright 2014 R. S. Ananda Murthy, Mysore, India
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=iTest
- VERSION=${VERSION:-1.4.2_PREVIEW4}
- SRCVER=$(echo $VERSION | tr _ -)
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION-src
- tar xvf $CWD/$PRGNAM-$SRCVER-src.tar.gz
- cd $PRGNAM-$SRCVER-src
- # Replace-direct-calls-to-constructor
- find . -name "*.cpp" -type f -exec sed -i -e 's|QColor::QColor|QColor|g' -e 's|QBrush::QBrush|QBrush|g' -e 's|QDate::QDate|QDate|g' -e 's|QTime::QTime|QTime|g' -e 's|QDateTime::QDateTime|QDateTime|g' -e 's|QIcon::QIcon|QIcon|g' -e 's|QSize::QSize|QSize|g' -e 's|QFont::QFont|QFont|g' {} \;
- find . -name "*.h" -type f -exec sed -i -e 's|QColor::QColor|QColor|g' -e 's|QBrush::QBrush|QBrush|g' -e 's|QDate::QDate|QDate|g' -e 's|QTime::QTime|QTime|g' -e 's|QDateTime::QDateTime|QDateTime|g' -e 's|QIcon::QIcon|QIcon|g' -e 's|QSize::QSize|QSize|g' -e 's|QFont::QFont|QFont|g' {} \;
- patch -p0 < $CWD/itestserver-session_cpp.diff
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- . /etc/profile.d/qt4.sh
- cd iTestServer
- lrelease iTestServer.pro
- cd ..
- cd iTestClient
- lrelease iTestClient.pro
- cd ..
- qmake -config release
- make
- #copying files to packaging directory
- cd $PKG
- mkdir -p $PKG/usr/bin
- mkdir -p $PKG/usr/share/{applications,icons/hicolor/48x48/apps}
- install -m 755 -p $TMP/$PRGNAM-$SRCVER-src/bin/iTestServer $PKG/usr/bin
- #create desktop file for server
- cat << "EOF" >$PKG/usr/share/applications/iTestServer.desktop
- [Desktop Entry]
- Encoding=UTF-8
- Name=iTest Server
- Exec=iTestServer
- Comment=iTest Server
- GenericName=iTest Server
- Terminal=false
- Type=Application
- Categories=Education;
- Icon=iTestServer
- EOF
- cp -f $TMP/$PRGNAM-$SRCVER-src/iTestServer/images/itest48.png $PKG/usr/share/icons/hicolor/48x48/apps/iTestServer.png
- install -m 755 -p $TMP/$PRGNAM-$SRCVER-src/bin/iTestClient $PKG/usr/bin
- #create desktop file
- cat << "EOF" >$PKG/usr/share/applications/iTestClient.desktop
- [Desktop Entry]
- Encoding=UTF-8
- Name=iTest Client
- Exec=iTestClient
- Comment=iTest Client
- GenericName=iTest Client
- Terminal=false
- Type=Application
- Categories=Education;
- Icon=iTestClient
- EOF
- cp -f $TMP/$PRGNAM-$SRCVER-src/iTestClient/images/itcl.png $PKG/usr/share/icons/hicolor/48x48/apps/iTestClient.png
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a $TMP/$PRGNAM-$SRCVER-src/readme.txt \
- $TMP/$PRGNAM-$SRCVER-src/gpl.txt $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|