PhyML.SlackBuild 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109
  1. #!/bin/sh
  2. # Slackware build script for PhyML
  3. # Copyright 2011-2012 Petar Petrov, ppetrov@paju.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Thanks to Niels Horn for some handy modifications and corrections.
  23. PRGNAM=PhyML
  24. VERSION=${VERSION:-20120412}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i486 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. CWD=$(pwd)
  36. TMP=${TMP:-/tmp/SBo}
  37. PKG=$TMP/package-$PRGNAM
  38. OUTPUT=${OUTPUT:-/tmp}
  39. if [ "$ARCH" = "i486" ]; then
  40. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  41. LIBDIRSUFFIX=""
  42. elif [ "$ARCH" = "i686" ]; then
  43. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  44. LIBDIRSUFFIX=""
  45. elif [ "$ARCH" = "x86_64" ]; then
  46. SLKCFLAGS="-O2 -fPIC"
  47. LIBDIRSUFFIX="64"
  48. else
  49. SLKCFLAGS="-O2"
  50. LIBDIRSUFFIX=""
  51. fi
  52. set -e
  53. rm -rf $PKG
  54. mkdir -p $TMP $PKG $OUTPUT
  55. cd $TMP
  56. rm -rf $SRCNAM-$VERSION
  57. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  58. cd $SRCNAM-$VERSION
  59. chown -R root:root .
  60. find . \
  61. \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  62. -exec chmod 755 {} \; -o \
  63. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  64. -exec chmod 644 {} \;
  65. ./configure \
  66. --prefix=/usr \
  67. --libdir=/usr/lib${LIBDIRSUFFIX} \
  68. --sysconfdir=/etc \
  69. --localstatedir=/var \
  70. --mandir=/usr/man \
  71. --docdir=/usr/doc/$PRGNAM-$VERSION \
  72. --build=$ARCH-slackware-linux
  73. # Use our CFLAGS
  74. sed -i "/^CFLAGS/s/=/+=/" src/Makefile
  75. sed -i "/^CFLAGS/s/=/+=/" Makefile
  76. CFLAGS="$SLKCFLAGS" \
  77. CXXFLAGS="$SLKCFLAGS" \
  78. make
  79. make install DESTDIR=$PKG
  80. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  81. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  82. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  83. cp -a \
  84. doc/$SRCNAM-manual-20120306.pdf AUTHORS ChangeLog COPYING INSTALL README \
  85. $PKG/usr/doc/$PRGNAM-$VERSION
  86. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  87. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  88. mkdir -p $PKG/install
  89. cat $CWD/slack-desc > $PKG/install/slack-desc
  90. cd $PKG
  91. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}