k9copy-reloaded.SlackBuild 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. #!/bin/bash
  2. # Slackware build script for k9copy-reloaded
  3. # Copyright 2018, 2020 by Lenard Spencer (lenardrspencer@gmail.com)
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=k9copy-reloaded
  25. SRCNAM=k9copy
  26. VERSION=${VERSION:-3.0.3}
  27. BUILD=${BUILD:-6}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $SRCNAM
  65. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  66. cd $SRCNAM
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # Insert a blank CmakeLists.txt file in various subs
  74. # or the build will fail
  75. touch src/libdvdnav-NOW/CMakeLists.txt
  76. touch src/libdvdnav-NOW/vm/CMakeLists.txt
  77. touch src/libdvdnav-NOW/dvdnav/CMakeLists.txt
  78. touch src/libdvdread-NOW/CMakeLists.txt
  79. touch src/libdvdread-NOW/dvdread/CMakeLists.txt
  80. patch -p1 < $CWD/patches/k9copy-fix-desktop-files.patch
  81. patch -p1 < $CWD/patches/k9copy-installdirs.patch
  82. patch -p1 < $CWD/patches/k9copy-ffmpeg3.patch
  83. # from the Fedora community, MUCH better than the ill-conceived and
  84. # BROKEN gcc6 patch that has been floating around the web:
  85. patch -p1 < $CWD/patches/k9copy-gcc7.patch
  86. # There have been several attempts to remove the internal libdvdread
  87. # and libdvdnav, but NONE of then work properly (the program builds,
  88. # but the backups are corrupt and will not play). I may revisit it
  89. # later, but for now, we must patch the internal dvdnav to properly
  90. # link to the internal dvdread: otherwise, the backups come out with
  91. # corrupted .IFO files:
  92. patch -p1 < $CWD/patches/k9copy-dvdnav.patch
  93. # In 15.0, dvdauthor crashes the program if we try to use it,
  94. # so we disable it by default in settings:
  95. patch -p1 < $CWD/patches/k9copy-uncheck-dvdauthor.patch
  96. # Patch for missing "Language=" entry in .po files:
  97. patch -p1 < $CWD/patches/k9copy-missing-language-in-po-files.patch
  98. # Patch for i18n (mitigates I18N_ARGUMENT_MISSING messages):
  99. patch -p1 < $CWD/patches/k9copy-i18n.patch
  100. mkdir -p build
  101. cd build
  102. cmake \
  103. -DCMAKE_C_FLAGS="$SLKCFLAGS" \
  104. -DCMAKE_CXX_FLAGS="$SLKCFLAGS -std=c++11" \
  105. -DCMAKE_INSTALL_PREFIX=/usr \
  106. -DQT5_BUILD="ON" \
  107. -DCMAKE_BUILD_TYPE=Release ..
  108. make
  109. make install DESTDIR=$PKG
  110. cd ..
  111. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  112. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  113. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  114. cp -a \
  115. COPYING README \
  116. $PKG/usr/doc/$PRGNAM-$VERSION
  117. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  118. mkdir -p $PKG/install
  119. cat $CWD/slack-desc > $PKG/install/slack-desc
  120. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  121. cd $PKG
  122. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE