123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145 |
- #!/bin/bash
- # Slackware build script for k9copy-reloaded
- # Copyright 2018, 2020 by Lenard Spencer (lenardrspencer@gmail.com)
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=k9copy-reloaded
- SRCNAM=k9copy
- VERSION=${VERSION:-3.0.3}
- BUILD=${BUILD:-6}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCNAM
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Insert a blank CmakeLists.txt file in various subs
- # or the build will fail
- touch src/libdvdnav-NOW/CMakeLists.txt
- touch src/libdvdnav-NOW/vm/CMakeLists.txt
- touch src/libdvdnav-NOW/dvdnav/CMakeLists.txt
- touch src/libdvdread-NOW/CMakeLists.txt
- touch src/libdvdread-NOW/dvdread/CMakeLists.txt
- patch -p1 < $CWD/patches/k9copy-fix-desktop-files.patch
- patch -p1 < $CWD/patches/k9copy-installdirs.patch
- patch -p1 < $CWD/patches/k9copy-ffmpeg3.patch
- # from the Fedora community, MUCH better than the ill-conceived and
- # BROKEN gcc6 patch that has been floating around the web:
- patch -p1 < $CWD/patches/k9copy-gcc7.patch
- # There have been several attempts to remove the internal libdvdread
- # and libdvdnav, but NONE of then work properly (the program builds,
- # but the backups are corrupt and will not play). I may revisit it
- # later, but for now, we must patch the internal dvdnav to properly
- # link to the internal dvdread: otherwise, the backups come out with
- # corrupted .IFO files:
- patch -p1 < $CWD/patches/k9copy-dvdnav.patch
- # In 15.0, dvdauthor crashes the program if we try to use it,
- # so we disable it by default in settings:
- patch -p1 < $CWD/patches/k9copy-uncheck-dvdauthor.patch
- # Patch for missing "Language=" entry in .po files:
- patch -p1 < $CWD/patches/k9copy-missing-language-in-po-files.patch
- # Patch for i18n (mitigates I18N_ARGUMENT_MISSING messages):
- patch -p1 < $CWD/patches/k9copy-i18n.patch
- mkdir -p build
- cd build
- cmake \
- -DCMAKE_C_FLAGS="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS="$SLKCFLAGS -std=c++11" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DQT5_BUILD="ON" \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
- cd ..
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a \
- COPYING README \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|