octave.SlackBuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. #!/bin/bash
  2. # Slackware build script for octave
  3. # Copyright 2012-2022 Kyle Guinn <elyk03@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=octave
  24. VERSION=${VERSION:-7.3.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$(uname -m)" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$(uname -m) ;;
  33. esac
  34. fi
  35. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  36. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  37. exit 0
  38. fi
  39. TMP=${TMP:-/tmp/SBo}
  40. PKG=$TMP/package-$PRGNAM-$VERSION
  41. OUTPUT=${OUTPUT:-/tmp}
  42. DOCS="AUTHORS BUGS CITATION COPYING ChangeLog INSTALL* NEWS README"
  43. if [ "$ARCH" = "i586" ]; then
  44. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "i686" ]; then
  47. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "x86_64" ]; then
  50. SLKCFLAGS="-O2 -fPIC"
  51. LIBDIRSUFFIX="64"
  52. else
  53. SLKCFLAGS="-O2"
  54. LIBDIRSUFFIX=""
  55. fi
  56. # Use GraphicsMagick by default. Fall back on ImageMagick from the full
  57. # Slackware install if it's not present.
  58. #
  59. # GraphicsMagick is default due to the fact that the Octave devs mainly test
  60. # with that, and went several releases before noticing ImageMagick was broken.
  61. # If ImageMagick doesn't work, install GraphicsMagick, or set MAGICK="".
  62. #
  63. # TODO: ImageMagick may no longer be compatible. The --with-magick argument
  64. # should be the name of a pkg-config file. Documentation suggests
  65. # "ImageMagick++" which does not exist. "ImageMagick" and "Magick++" exist;
  66. # the former does not pass configure checks, the latter fails at compile time.
  67. MAGICK=${MAGICK-GraphicsMagick++}
  68. if [ -n "$MAGICK" ] && ! pkg-config --exists $MAGICK; then
  69. MAGICK=ImageMagick
  70. fi
  71. if [ -n "$MAGICK" ]; then
  72. MAGICK="--with-magick=$MAGICK"
  73. fi
  74. set -e
  75. rm -rf $PKG
  76. mkdir -p $TMP $PKG $OUTPUT
  77. cd $TMP
  78. rm -rf $PRGNAM-$VERSION
  79. tar xvf $CWD/$PRGNAM-$VERSION.tar.lz
  80. cd $PRGNAM-$VERSION
  81. chown -R root:root .
  82. chmod -R u+w,go-w,a+rX-st .
  83. patch -p1 < $CWD/patches/atlas-lib-rename.diff
  84. autoreconf -vif
  85. # Avoid rebuilding the documentation by making stamp-vti newer than its
  86. # dependencies (in particular ./configure, which we may need to patch).
  87. # If you live far enough east or west that the date contained in version.texi
  88. # does not match that file's timestamp when printed accounting for your
  89. # timezone, then the docs get rebuilt with your local date.
  90. find . -name stamp-vti -exec touch {} +
  91. ./configure \
  92. --prefix=/usr \
  93. --libdir=\${prefix}/lib${LIBDIRSUFFIX} \
  94. --sysconfdir=/etc \
  95. --localstatedir=/var \
  96. --mandir=\${prefix}/man \
  97. --infodir=\${prefix}/info \
  98. --docdir=\${prefix}/doc/$PRGNAM-$VERSION \
  99. --disable-dependency-tracking \
  100. --with-openssl=auto \
  101. ${MAGICK} \
  102. --build=$ARCH-slackware-linux \
  103. CFLAGS="$SLKCFLAGS" \
  104. CXXFLAGS="$SLKCFLAGS" \
  105. FFLAGS="$SLKCFLAGS" \
  106. make
  107. # TODO: May fail if not all optional deps are installed (gl2ps in particular).
  108. #make check
  109. make install-strip DESTDIR=$PKG
  110. find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
  111. find $PKG/usr/man -type f -exec gzip -9 {} +
  112. rm -f $PKG/usr/info/dir
  113. gzip -9 $PKG/usr/info/*.info*
  114. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  115. cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
  116. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  117. mkdir -p $PKG/install
  118. cat $CWD/slack-desc > $PKG/install/slack-desc
  119. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  120. cd $PKG
  121. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE