ncbi-blast.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121
  1. #!/bin/bash
  2. # Slackware build script for ncbi-blast
  3. # Copyright 2013-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=ncbi-blast
  24. VERSION=${VERSION:-2.2.26}
  25. BUILD=${BUILD:-2}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCNAM=blast
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i386 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. set -e
  47. if [ "$ARCH" != "i386" ] && [ "$ARCH" != "x86_64" ]; then
  48. printf "\n\n$ARCH is not supported... \n"
  49. exit 1
  50. fi
  51. # Determine the source arch
  52. if [ "$ARCH" = "x86_64" ]; then
  53. SRCARCH="x64"
  54. else
  55. SRCARCH="ia32"
  56. fi
  57. # Construct the tarball name
  58. TARNAME=$SRCNAM-$VERSION-$SRCARCH-linux
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $SRCNAM-$VERSION
  63. tar xvf $CWD/$TARNAME.tar.gz
  64. cd $SRCNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  68. -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  70. -exec chmod 644 {} \;
  71. # Install the precompiled binaries. Change the name of rpsblast and
  72. # seedtop as they are also part of the ncbi-blast+ package.
  73. cd bin
  74. install -D -m755 bl2seq $PKG/usr/bin/bl2seq
  75. install -D -m755 blastall $PKG/usr/bin/blastall
  76. install -D -m755 blastclust $PKG/usr/bin/blastclust
  77. install -D -m755 blastpgp $PKG/usr/bin/blastpgp
  78. install -D -m755 copymat $PKG/usr/bin/copymat
  79. install -D -m755 fastacmd $PKG/usr/bin/fastacmd
  80. install -D -m755 formatdb $PKG/usr/bin/formatdb
  81. install -D -m755 formatrpsdb $PKG/usr/bin/formatrpsdb
  82. install -D -m755 impala $PKG/usr/bin/impala
  83. install -D -m755 makemat $PKG/usr/bin/makemat
  84. install -D -m755 megablast $PKG/usr/bin/megablast
  85. install -D -m755 rpsblast $PKG/usr/bin/rpsblast-legacy
  86. install -D -m755 seedtop $PKG/usr/bin/seedtop-legacy
  87. cd ..
  88. # Copy data dir
  89. mkdir -p $PKG/usr/share/$PRGNAM
  90. cp -a data $PKG/usr/share/$PRGNAM
  91. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  92. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  93. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  94. cp -a \
  95. doc/* VERSION \
  96. $PKG/usr/doc/$PRGNAM-$VERSION
  97. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  98. mkdir -p $PKG/install
  99. cat $CWD/slack-desc > $PKG/install/slack-desc
  100. cd $PKG
  101. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE