megax.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. #!/bin/bash
  2. # Slackware build script for megax (formerly 'megacc', called now simply 'mega')
  3. # This takes the place of "megacc" in 2018, as it includes also the GUI
  4. # of the program (megax) in addition to megacc.
  5. # Copyright 2017-2020 Petar Petrov slackalaxy@gmail.com
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=megax
  26. VERSION=${VERSION:-11.0.11_1}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. SRCNAM=mega
  31. DEBVER=$(echo $VERSION | tr _ -)
  32. if [ -z "$ARCH" ]; then
  33. case "$( uname -m )" in
  34. i?86) ARCH=i386 ;;
  35. arm*) ARCH=arm ;;
  36. *) ARCH=$( uname -m ) ;;
  37. esac
  38. fi
  39. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  40. # the name of the created package would be, and then exit. This information
  41. # could be useful to other scripts.
  42. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  43. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  44. exit 0
  45. fi
  46. TMP=${TMP:-/tmp/SBo}
  47. PKG=$TMP/package-$PRGNAM
  48. OUTPUT=${OUTPUT:-/tmp}
  49. if [ "$ARCH" = "i386" ] || [ "$ARCH" = "i486" ] || [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
  50. LIBDIRSUFFIX=""
  51. DEBARCH="i386"
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. LIBDIRSUFFIX="64"
  54. DEBARCH="amd64"
  55. else
  56. printf "\n\n$ARCH is not supported... \n"
  57. exit 1
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAM-$VERSION
  64. mkdir $PRGNAM-$VERSION
  65. cd $PRGNAM-$VERSION
  66. ar p $CWD/${SRCNAM}_${DEBVER}_${DEBARCH}.deb data.tar.xz | tar xJv
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # Fix path in runmega.sh for x86_64
  74. sed -i "s|/usr/lib/megax|/usr/lib${LIBDIRSUFFIX}/$PRGNAM|g" usr/lib/mega/runmega.sh
  75. # Place things in /usr/lib and just create symlinks later.
  76. # This is what Debian's and RedHat's packages do.
  77. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
  78. cp -a usr/lib/mega $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM
  79. # Copy man pages to their proper place.
  80. cp -a usr/local/share/man $PKG/usr
  81. sed -i "s:lib:lib${LIBDIRSUFFIX}:" $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM/runmega.sh
  82. sed -i "s:mega:$PRGNAM:" $PKG/usr/lib${LIBDIRSUFFIX}/$PRGNAM/runmega.sh
  83. mkdir -p $PKG/usr/bin
  84. cd $PKG/usr/bin
  85. ln -s ../lib${LIBDIRSUFFIX}/$PRGNAM/megacc
  86. ln -s ../lib${LIBDIRSUFFIX}/$PRGNAM/runmega.sh runmega
  87. cd -
  88. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  89. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  90. find $PKG/usr/man -type f -exec gzip -9 {} \;
  91. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  92. # Menu entry for MEGA X, use our .desktop file
  93. mkdir -p $PKG/usr/share/{applications,pixmaps}
  94. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  95. cp usr/share/pixmaps/mega.png $PKG/usr/share/pixmaps/megax.png
  96. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  97. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  98. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  99. mkdir -p $PKG/install
  100. cat $CWD/slack-desc > $PKG/install/slack-desc
  101. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  102. cd $PKG
  103. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE