fiji.SlackBuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150
  1. #!/bin/bash
  2. # Slackware build script for fiji
  3. # Copyright 2018-2022 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=fiji
  24. VERSION=${VERSION:-20220414_1745}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. DIRNAM=Fiji.app
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i386 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. set -e
  47. # Stop if arch is not supported
  48. if [ "$ARCH" != "i386" ] && [ "$ARCH" != "x86_64" ]; then
  49. printf "\n\n$ARCH is not supported... \n"
  50. exit 1
  51. fi
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf $DIRNAM
  56. tar xvf $CWD/${PRGNAM}-linux64.tar.gz
  57. cd $DIRNAM
  58. chown -R root:root .
  59. find -L . \
  60. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  61. -o -perm 511 \) -exec chmod 755 {} \; -o \
  62. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  63. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  64. # Rename the binary we need
  65. mv ImageJ-linux64 $PRGNAM
  66. # We will put here two tools, so they are not run at startup.
  67. mkdir -p unused
  68. cd unused
  69. # Remove the check for required updates. If you want it, comment out
  70. # the next line. You can "enable" it any time by just placing it in the
  71. # plugins/Scripts/Plugins/AutoRun/ folder.
  72. mv ../plugins/Scripts/Plugins/AutoRun/Check_Required_Update_Sites.js .
  73. # We do not want updates when the program is installed. As above, it
  74. # is your system, so if you want this functionality, then comment out
  75. # the line below. You can always "enable" it, by placing it in the jars
  76. # folder.
  77. mv ../jars/imagej-updater-* .
  78. cd ..
  79. # Update plugins, so that the latest are included in the package. This
  80. # will download stuff during the package creation, something that is
  81. # against the policy of SlackBuilds.org. However, it is _your_ system,
  82. # so if you _really_ want this, uncomment the line below.
  83. # ./$PRGNAM --update list-local-only
  84. # Copy the folders, db.xml and the renamed binary to /opt
  85. mkdir -p $PKG/opt/$PRGNAM
  86. cp -a \
  87. Contents \
  88. images \
  89. jars \
  90. java \
  91. lib \
  92. licenses \
  93. luts \
  94. macros \
  95. plugins \
  96. retro \
  97. scripts \
  98. db.xml.gz \
  99. $PRGNAM \
  100. $PKG/opt/$PRGNAM
  101. # If a file called "ImageJ2.desktop" is not present in the directory
  102. # of fiji, it will create (and re-create it if you delete it) the file
  103. # "~/.local/share/applications/ImageJ2.desktop" upon start. So, let it
  104. # have its desktop file. This is a very stupid workaround, but it is
  105. # really the best I could think of. At first I thought that deleting
  106. # "plugins/Scripts/Plugins/Utilities/Create_Desktop_Icon.bsh" will do
  107. # the trick, but no...
  108. cp $CWD/ImageJ2.desktop $PKG/opt/$PRGNAM
  109. # Install the simple wrapper
  110. install -D -m755 $CWD/$PRGNAM $PKG/usr/bin/$PRGNAM
  111. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  112. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  113. mkdir -p $PKG/usr/share/{applications,pixmaps}
  114. cp $CWD/ImageJ2.desktop $PKG/usr/share/applications
  115. cp images/icon.png $PKG/usr/share/pixmaps/$PRGNAM.png
  116. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  117. cp -a README.md WELCOME.md $PKG/usr/doc/$PRGNAM-$VERSION
  118. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  119. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  120. mkdir -p $PKG/install
  121. cat $CWD/slack-desc > $PKG/install/slack-desc
  122. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  123. cd $PKG
  124. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE