elk.SlackBuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. #!/bin/bash
  2. # Slackware build script for elk
  3. # Copyright 2022 William PC - Seattle, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=elk
  24. VERSION=${VERSION:-8.5.10}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION.tgz
  64. cd $PRGNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. # set default compiler flags to all modes
  72. # NOTE: doesn't compile without openmp
  73. FORTRAN_COMPILER="gfortran"
  74. BUILD_FLAGS="-Wall -std=legacy -fopenmp"
  75. if [ "${OMP_OPT:-no}" == "yes" ]; then
  76. BUILD_FLAGS="$BUILD_FLAGS -ffast-math -funroll-loops -fopenmp"
  77. fi
  78. if [ "${MPI:-no}" == "yes" ]; then
  79. FORTRAN_COMPILER="mpif90"
  80. fi
  81. # configure building
  82. echo > make.inc
  83. echo "MAKE = make" >> make.inc
  84. echo "F90 = $FORTRAN_COMPILER" >> make.inc
  85. echo "F90_OPTS = -O2 $BUILD_FLAGS" >> make.inc
  86. echo "F77 = $FORTRAN_COMPILER" >> make.inc
  87. echo "F77_OPTS = -O2 $BUILD_FLAGS" >> make.inc
  88. echo "AR = ar" >> make.inc
  89. echo "LIB_LPK = lapack.a blas.a" >> make.inc
  90. echo "LIB_FFT = fftlib.a" >> make.inc
  91. cat make.def >> make.inc
  92. if [ "${LIBXC:-no}" == "yes" ]; then
  93. sed -i '47aLIB_libxc = /usr/lib'${LIBDIRSUFFIX}'/libxc.so' make.inc
  94. sed -i 's/^#SRC_libxc/SRC_libxc/' make.inc
  95. fi
  96. # fix eos and spacegroup makefile "cannot open module file modmain.mod"
  97. sed -i '20s/$(OBJ)/$(SRC)/' src/eos/Makefile
  98. sed -i '20a\\t$(F90) $(F90_OPTS) -c $(SRC)' src/eos/Makefile
  99. sed -i '28s/$(OBJ)/$(SRC)/' src/spacegroup/Makefile
  100. sed -i '28a\\t$(F90) $(F90_OPTS) -c $(SRC)' src/spacegroup/Makefile
  101. make all
  102. # not rule to install, so perform it manually
  103. install -d $PKG/usr/bin
  104. install -m 755 src/elk $PKG/usr/bin
  105. install -d $PKG/usr/libexec/$PRGNAM
  106. install -m 755 src/{grepelk,protex,rmspaces,vimelk} $PKG/usr/libexec/$PRGNAM
  107. install -m 755 src/eos/eos $PKG/usr/libexec/$PRGNAM
  108. install -m 755 src/spacegroup/spacegroup $PKG/usr/libexec/$PRGNAM
  109. # install examples and some tools
  110. mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
  111. cp -a examples species utilities $PKG/usr/share/$PRGNAM-$VERSION
  112. # update examples to search expecies at system installation path
  113. for file in $(grep -lr "" $PKG/usr/share/$PRGNAM-$VERSION/examples); do
  114. sed -i 's#\(../../..\)\(/species\)#/usr/share/'$PRGNAM-$VERSION'\2#' $file
  115. done
  116. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  117. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  118. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  119. cp -a \
  120. COPYING docs \
  121. $PKG/usr/doc/$PRGNAM-$VERSION
  122. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  123. mkdir -p $PKG/install
  124. cat $CWD/slack-desc > $PKG/install/slack-desc
  125. cd $PKG
  126. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE