ITK.SlackBuild 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174
  1. #!/bin/bash
  2. # SlackBuild script for ITK
  3. # Copyright 2018-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use in source and binary forms, with or without
  7. # modification, are permitted provided that the following conditions are
  8. # met:
  9. #
  10. # * Redistributions of source code must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  14. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  15. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  16. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  17. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  19. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  20. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  21. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  22. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  23. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=ITK
  26. SRCNAM=InsightToolkit
  27. VERSION=${VERSION:-4.13.2}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "i686" ]; then
  52. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "x86_64" ]; then
  55. SLKCFLAGS="-O2 -fPIC"
  56. LIBDIRSUFFIX="64"
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $SRCNAM-$VERSION
  66. tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
  67. cd $SRCNAM-$VERSION
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \; -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  74. patch -p1 <<'endpatch'
  75. --- InsightToolkit-4.13.2/Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h.cp
  76. +++ InsightToolkit-4.13.2/Modules/ThirdParty/VNL/src/vxl/vcl/vcl_compiler.h
  77. @@ -96,6 +96,39 @@
  78. # define VCL_GCC_81
  79. # else
  80. # define VCL_GCC_80
  81. +# endif
  82. +# elif (__GNUC__==9)
  83. +# define VCL_GCC_9
  84. +# if (__GNUC_MINOR__ > 2 )
  85. +# define VCL_GCC_93
  86. +# elif (__GNUC_MINOR__ > 1 )
  87. +# define VCL_GCC_92
  88. +# elif (__GNUC_MINOR__ > 0 )
  89. +# define VCL_GCC_91
  90. +# else
  91. +# define VCL_GCC_90
  92. +# endif
  93. +# elif (__GNUC__==10)
  94. +# define VCL_GCC_10
  95. +# if (__GNUC_MINOR__ > 2 )
  96. +# define VCL_GCC_103
  97. +# elif (__GNUC_MINOR__ > 1 )
  98. +# define VCL_GCC_102
  99. +# elif (__GNUC_MINOR__ > 0 )
  100. +# define VCL_GCC_101
  101. +# else
  102. +# define VCL_GCC_100
  103. +# endif
  104. +# elif (__GNUC__==11)
  105. +# define VCL_GCC_11
  106. +# if (__GNUC_MINOR__ > 2 )
  107. +# define VCL_GCC_113
  108. +# elif (__GNUC_MINOR__ > 1 )
  109. +# define VCL_GCC_112
  110. +# elif (__GNUC_MINOR__ > 0 )
  111. +# define VCL_GCC_111
  112. +# else
  113. +# define VCL_GCC_110
  114. # endif
  115. # else
  116. # error "Dunno about this gcc"
  117. endpatch
  118. sed -i "s/lib\b/lib${LIBDIRSUFFIX}/" CMakeLists.txt
  119. sed -i "s|/opj_config.h|& \$\{CMAKE_CURRENT_BINARY_DIR\}/openjpeg_mangle.h|" \
  120. Modules/ThirdParty/GDCM/src/gdcm/Utilities/gdcmopenjpeg/src/lib/openjp2/CMakeLists.txt
  121. mkdir -p build
  122. cd build
  123. cmake \
  124. -DCMAKE_C_FLAGS="$SLKCFLAGS" \
  125. -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
  126. -DCMAKE_INSTALL_PREFIX=/usr \
  127. -DITK_FORBID_DOWNLOADS=ON \
  128. -DITK_WRAP_PYTHON=OFF \
  129. -DBUILD_SHARED_LIBS=ON \
  130. -DBUILD_EXAMPLES=OFF \
  131. -DITK_USE_SYSTEM_LIBRARIES=ON \
  132. -DITK_USE_SYSTEM_DCMTK=ON \
  133. -DITK_USE_SYSTEM_DOUBLECONVERSION=ON \
  134. -DITK_USE_SYSTEM_EXPAT=ON \
  135. -DITK_USE_SYSTEM_FFTW=ON \
  136. -DITK_USE_SYSTEM_HDF5=ON \
  137. -DITK_USE_SYSTEM_JPEG=ON \
  138. -DITK_USE_SYSTEM_PNG=ON \
  139. -DITK_USE_SYSTEM_TIFF=ON \
  140. -DITK_USE_SYSTEM_ZLIB=ON \
  141. -DCMAKE_BUILD_TYPE=Release ..
  142. make install DESTDIR=$PKG
  143. cd ..
  144. # remove pkg-config file for openjpeg since this overwrites system package for something that should be internal to ITK
  145. rm -rf $PKG/usr/lib64/pkgconfig
  146. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  147. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  148. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  149. mv $PKG/usr/share/doc/$PRGNAM-$(echo $VERSION | cut -d "." -f 1,2)/* $PKG/usr/doc/$PRGNAM-$VERSION
  150. rm -r $PKG/usr/share/doc
  151. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  152. mkdir $PKG/install
  153. cat $CWD/slack-desc > $PKG/install/slack-desc
  154. cd $PKG
  155. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE