PKGBUILD.in 753 B

12345678910111213141516171819202122232425262728293031
  1. # Maintainer: Cedric Leporcq <cedric at gmail dot com>
  2. pkgname=@PACKAGE_NAME@
  3. pkgver=@PACKAGE_VERSION@
  4. pkgrel=1
  5. pkgdesc="Xfce panel plugin which allows to put the maximized window title and buttons on the panel."
  6. arch=('i686' 'x86_64')
  7. url="https://github.com/cedl38/xfce4-windowck-plugin"
  8. license=('GPL3')
  9. groups=('xfce4')
  10. depends=('xfce4-panel')
  11. makedepends=('intltool' 'xfce4-dev-tools' 'python3' 'imagemagick')
  12. options=('!libtool')
  13. install=$pkgname.install
  14. source=("$pkgname-$pkgver.tar.gz::https://github.com/cedl38/$pkgname/archive/v$pkgver.tar.gz")
  15. sha256sums=('SKIP')
  16. build() {
  17. cd "$srcdir/${pkgname}-$pkgver"
  18. ./autogen.sh \
  19. --prefix=/usr
  20. make
  21. }
  22. package() {
  23. cd "$srcdir/${pkgname}-$pkgver"
  24. make DESTDIR="$pkgdir" install
  25. }