home.nix 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. { pkgs, ... }:
  2. {
  3. home.file = {
  4. ".mozilla/firefox/tmp/mimeTypes.rdf".text = builtins.readFile ./mimeTypes.rdf;
  5. };
  6. manual.manpages.enable = false;
  7. programs.firefox = {
  8. enable = true;
  9. package = pkgs.firefox;
  10. profiles = {
  11. tmp = {
  12. name = "tmp";
  13. id = 0;
  14. isDefault = true;
  15. settings = {
  16. "browser.startup.homepage" = "about:newtab";
  17. "startup.homepage_welcome_url" = "about:newtab";
  18. "browser.startup.page" = 3;
  19. "general.warnOnAboutConfig" = false;
  20. "browser.shell.checkDefaultBrowser" = false;
  21. "toolkit.telemetry.reportingpolicy.firstRun" = false;
  22. "plugin.state.java" = 2; # IcedTea set Always Activate
  23. # https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/375194
  24. #
  25. # Java is looking around for various proxy settings to try to
  26. # determine them, and doesn't understand Firefox's "5" type.
  27. # Changing "network.proxy.type" to 0 ("Direct connection, no proxy")
  28. # causes javaws to make a direct connection.
  29. # "network.proxy.type" = 0;
  30. "browser.newtabpage.pinned" = builtins.toJSON [
  31. null
  32. {
  33. baseDomain = "chat.openai.com";
  34. frecency = 100;
  35. lastVisitDate = 1643049209841467;
  36. title = "ChatGPT";
  37. type = "history";
  38. url = "https://chat.openai.com/";
  39. }
  40. ];
  41. "browser.search.region" = "GB";
  42. "distribution.searchplugins.defaultLocale" = "en-GB";
  43. "general.useragent.locale" = "en-GB";
  44. "browser.search.defaultenginename" = "Google";
  45. "network.proxy.type" = 1;
  46. "network.proxy.socks" = "192.168.154.93";
  47. "network.proxy.socks_port" = 1080;
  48. "network.proxy.socks_remote_dns" = true;
  49. };
  50. };
  51. };
  52. };
  53. }