flake.nix 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. {
  2. description = "";
  3. nixConfig = {
  4. substituters = [ "https://cache.nixos.intr/" ];
  5. trustedPublicKeys = [ "cache.nixos.intr:6VD7bofl5zZFTEwsIDsUypprsgl7r9I+7OGY4WsubFA=" ];
  6. };
  7. inputs = {
  8. deploy-rs.url = "github:serokell/deploy-rs";
  9. flake-compat = { url = "github:edolstra/flake-compat"; flake = false; };
  10. flake-utils.url = "github:numtide/flake-utils";
  11. majordomo.url = "git+https://gitlab.intr/_ci/nixpkgs";
  12. };
  13. outputs = { self, flake-utils, nixpkgs, majordomo, deploy-rs, ... } @ inputs:
  14. flake-utils.lib.eachDefaultSystem (system: {
  15. devShell = with nixpkgs.legacyPackages."\${system}"; mkShell {
  16. buildInputs = [
  17. nixFlakes
  18. deploy-rs.outputs.packages.\${system}.deploy-rs
  19. ];
  20. shellHook = ''
  21. . \${nixFlakes}/share/bash-completion/completions/nix
  22. export LANG=C
  23. '';
  24. };
  25. })
  26. // (let
  27. system = "x86_64-linux";
  28. in
  29. {
  30. # packages.\${system} =
  31. # checks.\${system} =
  32. # defaultPackage.\${system} = self.packages.\${system}.
  33. });
  34. }