default.nix 884 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. with import <nixpkgs> {};
  2. stdenv.mkDerivation rec {
  3. name = "otfcc-${version}";
  4. version = "0.9.6";
  5. src = fetchFromGitHub {
  6. owner = "caryll";
  7. repo = "otfcc";
  8. rev = "v${version}";
  9. sha256 = "1rnjfqqyc6d9nhlh8if9k37wk94mcwz4wf3k239v6idg48nrk10b";
  10. };
  11. buildInputs = [ clang gcc gnumake premake5 ];
  12. configurePhase = ''
  13. premake5 gmake
  14. '';
  15. buildPhase = ''
  16. cd build/gmake
  17. make config=release_x64
  18. cd -
  19. '';
  20. installPhase = ''
  21. mkdir -p $out/bin
  22. cp bin/release-x64/libotfccdll.so $out/bin
  23. cp bin/release-x64/otfccbuild $out/bin
  24. cp bin/release-x64/otfccdump $out/bin
  25. '';
  26. meta = with stdenv.lib; {
  27. description = "Optimized OpenType builder and inspector";
  28. homepage = "https://github.com/caryll/otfcc";
  29. license = licenses.asl20;
  30. maintainers = with maintainers; [ vyp ];
  31. platforms = platforms.all;
  32. };
  33. }