caps2esc.nix 656 B

12345678910111213141516171819202122
  1. { stdenv, fetchurl, cmake }:
  2. stdenv.mkDerivation rec {
  3. version = "0.1.0";
  4. name = "interception-tools-caps2esc-${version}";
  5. src = fetchurl {
  6. url = "https://gitlab.com/interception/linux/plugins/caps2esc/repository/v${version}/archive.tar.gz";
  7. sha256 = "1fdxqp54gwsrm2c63168l256nfwdk4mvgr7nlwdv62wd3l7zzrg8";
  8. };
  9. buildInputs = [ cmake ];
  10. meta = with stdenv.lib; {
  11. description = "Transforming the most useless key ever into the most useful one";
  12. homepage = "https://gitlab.com/interception/linux/plugins/caps2esc";
  13. license = licenses.mit;
  14. maintainers = with maintainers; [ vyp ];
  15. platforms = platforms.linux;
  16. };
  17. }