default.nix 740 B

12345678910111213141516171819202122232425
  1. with import <nixpkgs> {};
  2. let
  3. version = "2017-10-27";
  4. in fetchzip {
  5. name = "eb-garamond12-${version}";
  6. url = "https://github.com/octaviopardo/EBGaramond12/archive/19f27c58d8c5a5e2e863c36eaaf6988f9de83b20.zip";
  7. sha256 = "1d3sk2y8glbzpsc27f8nmjgrn3khi4mr558jwm3bwfy5x2zw1idh";
  8. postFetch = ''
  9. unzip $downloadedFile
  10. mkdir -p $out/share/fonts/eb-garamond12
  11. unzip -j $downloadedFile \*.otf -d $out/share/fonts/eb-garamond12
  12. '';
  13. meta = with stdenv.lib; {
  14. description = "Digitization of the Garamond shown on the Egenolff-Berner specimen";
  15. homepage = "https://github.com/octaviopardo/EBGaramond12";
  16. license = licenses.ofl;
  17. maintainers = with maintainers; [ vyp ];
  18. platforms = platforms.all;
  19. };
  20. }