station.nix 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, pkgs, flakeInputs, ... }:
  5. {
  6. imports =
  7. [ "${flakeInputs.nixpkgs}/nixos/modules/installer/scan/not-detected.nix" ];
  8. boot.initrd.availableKernelModules = [
  9. "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod"
  10. ];
  11. boot.initrd.kernelModules = [ ];
  12. boot.kernelModules = [ "kvm-amd" ];
  13. boot.extraModulePackages = [ ];
  14. boot.loader.systemd-boot.enable = true;
  15. boot.loader.efi.canTouchEfiVariables = true;
  16. networking.hostName = "station";
  17. networking.wireless.enable = true;
  18. networking.wireless.interfaces = [ "wlp3s0f0u4" ];
  19. networking.useDHCP = false;
  20. # networking.interfaces.enp34s0.useDHCP = true;
  21. networking.interfaces.wlp3s0f0u4.useDHCP = true;
  22. fileSystems."/" =
  23. { device = "/dev/disk/by-uuid/7695c728-6376-4857-9af8-2df9917450bb";
  24. fsType = "ext4";
  25. };
  26. fileSystems."/boot" =
  27. { device = "/dev/disk/by-uuid/94B9-7A06";
  28. fsType = "vfat";
  29. };
  30. fileSystems."/media/hdd1" =
  31. { device = "/dev/disk/by-uuid/97c7d7ed-53ae-416c-b531-5e0e15425040";
  32. fsType = "ext4";
  33. };
  34. swapDevices =
  35. [ { device = "/dev/disk/by-uuid/7cc0508e-e917-417d-a3c8-507a80390eb8"; }
  36. ];
  37. # This value determines the NixOS release from which the default
  38. # settings for stateful data, like file locations and database versions
  39. # on your system were taken. It‘s perfectly fine and recommended to leave
  40. # this value at the release version of the first install of this system.
  41. # Before changing this value read the documentation for this option
  42. # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
  43. system.stateVersion = "20.09"; # Did you read the comment?
  44. }