hosttools-gdb.spec 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. %{?!tool_name: %global tool_name hosttools}
  2. %global tool_prefix /opt/%{tool_name}
  3. Name: %{tool_name}-gdb
  4. Version: 11.2
  5. Release: 1%{?dist}
  6. Summary: GNU debugger
  7. License: GPLv3+
  8. URL: https://sourceware.org/gdb/
  9. Source0: https://ftp.gnu.org/gnu/gdb/gdb-11.2.tar.xz
  10. BuildRequires: gcc-c++ gmp-devel xz-devel ncurses-devel xxhash texinfo
  11. %description
  12. GNU debugger
  13. %prep
  14. %setup -q -n gdb-%{version}
  15. %build
  16. ./configure --prefix=%{tool_prefix} \
  17. --with-lzma \
  18. --with-xxhash=yes \
  19. --with-libxxhash-type=static \
  20. --disable-source-highlight \
  21. --enable-tui \
  22. --with-python=no --with-guile=no
  23. make %{?_smp_mflags}
  24. %install
  25. make -C gdb/data-directory DESTDIR="%{buildroot}" install
  26. make -C gdb DESTDIR="%{buildroot}" install
  27. make -C gdbserver DESTDIR="%{buildroot}" install
  28. rm -f %{buildroot}%{tool_prefix}/share/info/dir
  29. %files
  30. %{tool_prefix}/bin/*
  31. %{tool_prefix}/lib/libinproctrace.so
  32. %{tool_prefix}/share/gdb
  33. %{tool_prefix}/share/info/*
  34. %{tool_prefix}/share/man/*/*
  35. %{tool_prefix}/include/gdb/jit-reader.h
  36. %changelog