123456789101112131415161718192021222324252627282930313233343536373839404142434445464748 |
- %{?!tool_name: %global tool_name hosttools}
- %global tool_prefix /opt/%{tool_name}
- Name: %{tool_name}-gdb
- Version: 11.2
- Release: 1%{?dist}
- Summary: GNU debugger
- License: GPLv3+
- URL: https://sourceware.org/gdb/
- Source0: https://ftp.gnu.org/gnu/gdb/gdb-11.2.tar.xz
- BuildRequires: gcc-c++ gmp-devel xz-devel ncurses-devel xxhash texinfo
- %description
- GNU debugger
- %prep
- %setup -q -n gdb-%{version}
- %build
- ./configure --prefix=%{tool_prefix} \
- --with-lzma \
- --with-xxhash=yes \
- --with-libxxhash-type=static \
- --disable-source-highlight \
- --enable-tui \
- --with-python=no --with-guile=no
- make %{?_smp_mflags}
- %install
- make -C gdb/data-directory DESTDIR="%{buildroot}" install
- make -C gdb DESTDIR="%{buildroot}" install
- make -C gdbserver DESTDIR="%{buildroot}" install
- rm -f %{buildroot}%{tool_prefix}/share/info/dir
- %files
- %{tool_prefix}/bin/*
- %{tool_prefix}/lib/libinproctrace.so
- %{tool_prefix}/share/gdb
- %{tool_prefix}/share/info/*
- %{tool_prefix}/share/man/*/*
- %{tool_prefix}/include/gdb/jit-reader.h
- %changelog
|