config.spec 1.0 KB

12345678910111213141516171819202122232425
  1. [account]
  2. username = string(max=50)
  3. password = string(max=50)
  4. proxy = string(max=15)
  5. useragent = string(max=200)
  6. DNT = boolean(default=False)
  7. pinkerton = boolean(default=False)
  8. feed = boolean(default=False)
  9. [[gather]]
  10. area = option('earth', 'plague', 'wind', 'water', 'lightning', 'ice', 'shadow', 'light', 'arcane', 'nature', 'fire', default='earth')
  11. action = option('hunt', 'fish', 'catch', 'forage', 'dig', 'scavenge', default='hunt')
  12. [[bond]]
  13. mindelay = float(1, 60, default=2.0)
  14. maxdelay = float(1, 60, default=4.0)
  15. [[coliseum]]
  16. area = option('training_fields', 'woodland_border', 'scorched_forest', 'sandswept_delta', 'forgotten_cave', 'bamboo_waterfall', 'waterway', 'arena', 'boreal_wood', 'harpys_roost', 'mire', 'kelp_beds', default='training_fields')
  17. mindelay = float(1, 60, default=2.0)
  18. maxdelay = float(1, 60, default=4.0)
  19. trainingmode = boolean(default=False)
  20. trainingpos = integer(0, 2, default=2)
  21. debuglog = boolean(default=False)