PKGBUILD 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Maintainer: txtsd <aur.archlinux@ihavea.quest>
  2. pkgname=thesage
  3. pkgver=0.40.3028
  4. pkgrel=1
  5. pkgdesc='English Dictionary and Thesaurus. A twenty-first century lexical reference system.'
  6. arch=('x86_64')
  7. url='https://www.sequencepublishing.com/1/burbridge/beta_linux.html'
  8. license=('All Rights Reserved')
  9. depends=('zlib' 'bash')
  10. options=(!strip)
  11. source=("${pkgname}-${pkgver}.zip::https://www.sequencepublishing.com/cgi-bin/download.cgi?burbridgelinux"
  12. "${pkgname}.desktop"
  13. "${pkgname}.png")
  14. sha512sums=('aceeab22fadc9e8b1e8255bb7204df1fde329725d86d76256464ac43563e7280407ab1528d6c9f43301998104e4188e04f2a192afb51e0ed23e659e3e858f2fd'
  15. '9b7449ba7b3066be4fae5696011e4ff204d2f4e77750d110d46f5bfb04c8021957eaecdad61ffbafedec0e9c638a80e8ad7fe1ee3d5dedc6d5f7b6976a8e564b'
  16. '0ef714c8063eaa3abe730015acbdb976dadb6acdfb583df35bcf9ef15b5a0d27e48f42fec579b416fe8552a85b721b1f7ba1915d507594d870fe411b40d78aaf')
  17. package() {
  18. cd "${pkgdir}"
  19. install -dm777 "opt/${pkgname}"
  20. install -dm755 "usr/bin"
  21. install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
  22. install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
  23. rm "${srcdir}/${pkgname}-${pkgver}.zip"
  24. rm "${srcdir}/${pkgname}.desktop"
  25. rm "${srcdir}/${pkgname}.png"
  26. rm "${srcdir}/burbridge.ico"
  27. cp -a "${srcdir}/"* "${pkgdir}/opt/${pkgname}"
  28. cat > "${pkgdir}/usr/bin/thesage" << EOF
  29. #!/bin/sh
  30. /opt/thesage/Burbridge.exe
  31. EOF
  32. chmod +x "${pkgdir}/usr/bin/thesage"
  33. }