PKGBUILD 1.0 KB

12345678910111213141516171819202122232425
  1. # Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
  2. # Maintainer: txtsd <aur.archlinux@ihavea.quest>
  3. pkgname=prismlauncher-qt5-bin
  4. pkgver=6.3
  5. pkgrel=1
  6. pkgdesc="Minecraft launcher with ability to manage multiple instances."
  7. arch=('x86_64')
  8. url="https://prismlauncher.org"
  9. license=('GPL3')
  10. depends=('java-runtime' 'libgl' 'qt5-base' 'qt5-svg' 'qt5-imageformats' 'zlib' 'hicolor-icon-theme')
  11. provides=('prismlauncher' 'prismlauncher-qt5')
  12. conflicts=('prismlauncher' 'prismlauncher-qt5')
  13. optdepends=('java-runtime=8: support for Minecraft versions < 1.17'
  14. 'java-runtime=17: support for Minecraft versions >= 1.17')
  15. source=("https://github.com/PrismLauncher/PrismLauncher/releases/download/${pkgver}/PrismLauncher-Linux-${pkgver}.tar.gz")
  16. noextract=("PrismLauncher-Linux-${pkgver}.tar.gz")
  17. sha256sums=('621a950f09f162fa41c7e2a0123f1a4f95082c12b204a600b0697dcc275e6c44')
  18. package() {
  19. install -d "${pkgdir}/usr"
  20. tar -C "${pkgdir}/usr" -xvf PrismLauncher-Linux-${pkgver}.tar.gz
  21. chown -R root:root "${pkgdir}/usr" # files in tarball are not owned by root
  22. }