PKGBUILD 1.0 KB

12345678910111213141516171819202122232425
  1. # Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
  2. # Maintainer: txtsd <aur.archlinux@ihavea.quest>
  3. pkgname=prismlauncher-bin
  4. pkgver=6.3
  5. pkgrel=1
  6. pkgdesc="Minecraft launcher with ability to manage multiple instances."
  7. arch=('x86_64')
  8. url="https://prismlauncher.org"
  9. license=('GPL3')
  10. depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme')
  11. provides=('prismlauncher')
  12. conflicts=('prismlauncher')
  13. optdepends=('java-runtime=8: support for Minecraft versions < 1.17'
  14. 'java-runtime=17: support for Minecraft versions >= 1.17')
  15. source=("https://github.com/PrismLauncher/PrismLauncher/releases/download/${pkgver}/PrismLauncher-Linux-Qt6-${pkgver}.tar.gz")
  16. noextract=("PrismLauncher-Linux-Qt6-${pkgver}.tar.gz")
  17. sha256sums=('823d2e70fc98147c70cbf216102065a25dec3ba8149cb05f930bcde134392a86')
  18. package() {
  19. install -d "${pkgdir}/usr"
  20. tar -C "${pkgdir}/usr" -xvf PrismLauncher-Linux-Qt6-${pkgver}.tar.gz
  21. chown -R root:root "${pkgdir}/usr" # files in tarball are not owned by root
  22. }