PKGBUILD 2.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. # Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
  2. # Maintainer: txtsd <aur.archlinux@ihavea.quest>
  3. # Contributor: Elijah Gregg <lovetocode999 at tilde dot team>
  4. # Contributor: Lenny McLennington <lennymclennington@protonmail.com>
  5. # Contributor: Miko <mikoxyzzz@gmail.com>
  6. # Contributor: Cheru Berhanu <aur attt cheru doot dev>
  7. _pkgname=prismlauncher
  8. pkgname=${_pkgname}-git
  9. pkgver=6.0.r238.gdeed4957
  10. pkgrel=2
  11. pkgdesc="Minecraft launcher with ability to manage multiple instances."
  12. arch=('i686' 'x86_64' 'aarch64')
  13. url="https://prismlauncher.org"
  14. license=('GPL3')
  15. depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6' 'cmark' 'tomlplusplus')
  16. provides=('prismlauncher')
  17. conflicts=('prismlauncher')
  18. makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'ghc-filesystem' 'gamemode')
  19. optdepends=('glfw: to use system GLFW libraries'
  20. 'openal: to use system OpenAL libraries'
  21. 'visualvm: Profiling support'
  22. 'xorg-xrandr: for older minecraft versions'
  23. )
  24. options=(debug)
  25. source=("git+https://github.com/PrismLauncher/PrismLauncher.git"
  26. "git+https://github.com/PrismLauncher/libnbtplusplus.git")
  27. sha256sums=('SKIP'
  28. 'SKIP')
  29. pkgver() {
  30. cd "PrismLauncher"
  31. git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
  32. }
  33. prepare() {
  34. cd "PrismLauncher"
  35. git submodule init
  36. git config submodule.libraries/cmark.active false
  37. git config submodule.libraries/extra-cmake-modules.active false
  38. git config submodule.libraries/filesystem.active false
  39. git config submodule.libraries/libnbtplusplus.url "${srcdir}/libnbtplusplus"
  40. git config submodule.libraries/quazip.active false
  41. git config submodule.libraries/tomlplusplus.active false
  42. git config submodule.libraries/zlib.active false
  43. git -c protocol.file.allow=always submodule update
  44. }
  45. build() {
  46. cmake -DCMAKE_BUILD_TYPE= \
  47. -DCMAKE_INSTALL_PREFIX="/usr" \
  48. -DLauncher_APP_BINARY_NAME="${_pkgname}" \
  49. -DLauncher_QT_VERSION_MAJOR="6" \
  50. -Bbuild -SPrismLauncher
  51. cmake --build build
  52. }
  53. check() {
  54. cd "build"
  55. ctest .
  56. }
  57. package() {
  58. cd "build"
  59. DESTDIR="${pkgdir}" cmake --install .
  60. }