11 Commits be47151f25 ... 946292a290

Author SHA1 Message Date
  txtsd 946292a290 Add 'python-pox/' from commit '454e577568bc00a0f25e62c50a020f9ac9283165' 1 year ago
  txtsd 454e577568 upgpkg: python-pox 0.3.2-1 1 year ago
  Greyson Christoforo 3373ab247d bump version 3 years ago
  Grey Christoforo 099030dd7a drop python2 and bump version 4 years ago
  Grey Christoforo 4a6e7bbfc9 for python2-pox, rename /usr/bin/pox to /usr/bin/pox2 6 years ago
  Grey Christoforo e7fbc4b106 version bump and re-split package 6 years ago
  Michel Zou c49d93318c typo 8 years ago
  Michel Zou 50ac545ce1 0.2.2 8 years ago
  Michel Zou 5c1b49f316 0.2.2 8 years ago
  Michel Zou e5977ff106 optimize 8 years ago
  Michel Zou f449368d39 0.2.2 8 years ago
3 changed files with 46 additions and 0 deletions
  1. 16 0
      python-pox/.SRCINFO
  2. 5 0
      python-pox/.gitignore
  3. 25 0
      python-pox/PKGBUILD

+ 16 - 0
python-pox/.SRCINFO

@@ -0,0 +1,16 @@
+pkgbase = python-pox
+	pkgdesc = utilities for filesystem exploration and automated builds
+	pkgver = 0.3.2
+	pkgrel = 1
+	url = https://github.com/uqfoundation/pox
+	arch = any
+	license = BSD
+	makedepends = python-setuptools>=42.0
+	makedepends = python-build
+	makedepends = python-installer
+	makedepends = python-wheel
+	depends = python>=3.7
+	source = python-pox-0.3.2.tar.gz::https://github.com/uqfoundation/pox/archive/refs/tags/pox-0.3.2.tar.gz
+	sha256sums = 4a2573d7b64a4fe3c337b9d996d80089d0920c60d7920f94a4a2d14a8da8b202
+
+pkgname = python-pox

+ 5 - 0
python-pox/.gitignore

@@ -0,0 +1,5 @@
+src/
+pkg/
+
+*.pkg.*
+*.tar.*

+ 25 - 0
python-pox/PKGBUILD

@@ -0,0 +1,25 @@
+# Maintainer: greyltc
+# Contributor: txtsd <aur.archlinux@ihavea.quest>
+
+pkgname=python-pox
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="utilities for filesystem exploration and automated builds"
+url="https://github.com/uqfoundation/pox"
+arch=(any)
+license=('BSD')
+depends=('python>=3.7')
+makedepends=('python-setuptools>=42.0' 'python-build' 'python-installer' 'python-wheel')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/uqfoundation/pox/archive/refs/tags/pox-${pkgver}.tar.gz")
+sha256sums=('4a2573d7b64a4fe3c337b9d996d80089d0920c60d7920f94a4a2d14a8da8b202')
+
+build() {
+  cd "pox-pox-${pkgver}"
+  python -m build --wheel --no-isolation
+}
+
+package() {
+  cd "pox-pox-${pkgver}"
+  python -m installer --destdir="${pkgdir}" dist/*.whl
+  install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}