28 کامیت‌ها 946292a290 ... ca73446ff2

نویسنده SHA1 پیام تاریخ
  txtsd ca73446ff2 Split 'linux-command-gpt-git/' into commit '4a4b51fbc0b22dc0b6ba869cea94abdc6a0c44c6' 1 سال پیش
  txtsd ea140120e7 Split 'linux-command-gpt/' into commit 'a18b87081ef4bba04bc6e2fc81e4185ee8d93942' 1 سال پیش
  txtsd 4a4b51fbc0 upgpkg: linux-command-gpt-git v0.1.2.r0.g952eee1-2 1 سال پیش
  txtsd 71ddbc992e upgpkg: linux-command-gpt-git v0.1.2.r0.g952eee1-2 1 سال پیش
  txtsd b90863140e upgpkg: linux-command-gpt-git v0.1.2.r0.g952eee1-1 1 سال پیش
  txtsd 2b0db4e47e upgpkg: linux-command-gpt-git v0.1.2.r0.g952eee1-1 1 سال پیش
  txtsd a18b87081e upgpkg: linux-command-gpt 0.1.2-6 1 سال پیش
  txtsd c852844f43 upgpkg: linux-command-gpt 0.1.2-6 1 سال پیش
  txtsd f7174f352c upgpkg: linux-command-gpt 0.1.2-5 1 سال پیش
  txtsd 8386a2e7bd upgpkg: linux-command-gpt 0.1.2-5 1 سال پیش
  txtsd c4e565007c Add 'linux-command-gpt-git/' from commit '4557100d90e15b268ea1340ebd586c0944dcc50b' 1 سال پیش
  txtsd 18a459aab9 Add 'linux-command-gpt/' from commit 'e9e68a9449a0871b54c1a571615c953bf89cf445' 1 سال پیش
  Zeioth 4557100d90 Now we use 'install' 1 سال پیش
  Zeioth e9e68a9449 Now we use 'install' 1 سال پیش
  Zeioth 55dace0aa7 No need to checkout, I think. 1 سال پیش
  Zeioth 791df06d64 No need to checkout, I think. 1 سال پیش
  Zeioth f167cf78c8 Now we indicate the commit of the specific version. 1 سال پیش
  Zeioth 1a4fcaf30e safer cp command 1 سال پیش
  Zeioth 59125fa94b fix for cp 1 سال پیش
  Zeioth 00ace93f26 fix for cp 1 سال پیش
  Zeioth bbbb8af602 Let's indicate the right upstream version 1 سال پیش
  Zeioth eb064379c7 We copy the exetutable file instead of referencing 1 سال پیش
  Zeioth 1fdf8ac055 We copy the exetutable file instead of referencing 1 سال پیش
  Zeioth 61f147ded1 We copy the exetutable file instead of referencing 1 سال پیش
  Zeioth 30d451df47 Writing the actual original pkgver 1 سال پیش
  Zeioth 4b18b1dab6 Now we differentiate between stable and git version 1 سال پیش
  Zeioth 6a8403b6d8 Now we differentiate between stable and git version 1 سال پیش
  Zeioth 9591f82784 INITIAL COMMIT 1 سال پیش

+ 17 - 0
linux-command-gpt-git/.SRCINFO

@@ -0,0 +1,17 @@
+pkgbase = linux-command-gpt-git
+	pkgdesc = Get Linux commands in natural language with the power of ChatGPT
+	pkgver = v0.1.2.r0.g952eee1
+	pkgrel = 2
+	url = https://github.com/asrul10/linux-command-gpt
+	arch = x86_64
+	arch = aarch64
+	license = MIT
+	makedepends = git
+	makedepends = go
+	depends = glibc
+	provides = linux-command-gpt
+	conflicts = linux-command-gpt
+	source = git+https://github.com/asrul10/linux-command-gpt
+	sha256sums = SKIP
+
+pkgname = linux-command-gpt-git

+ 6 - 0
linux-command-gpt-git/.gitignore

@@ -0,0 +1,6 @@
+pkg/
+src/
+linux-command-gpt/
+
+*.pkg.*
+*.tar.*

+ 46 - 0
linux-command-gpt-git/PKGBUILD

@@ -0,0 +1,46 @@
+# Maintainer: Adrian Lopez <zeioth@hotmail.com>
+# Maintainer: txtsd <aur.archlinux@ihavea.quest>
+
+pkgname=linux-command-gpt-git
+_pkgname=linux-command-gpt
+pkgver=v0.1.2.r0.g952eee1
+pkgrel=2
+pkgdesc='Get Linux commands in natural language with the power of ChatGPT'
+arch=('x86_64' 'aarch64')
+url='https://github.com/asrul10/linux-command-gpt'
+license=('MIT')
+depends=('glibc')
+makedepends=('git' 'go')
+provides=('linux-command-gpt')
+conflicts=('linux-command-gpt')
+source=("git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+    cd "${_pkgname}"
+    git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+    cd "${_pkgname}"
+    # https://wiki.archlinux.org/index.php/Go_package_guidelines
+    export CGO_CPPFLAGS="${CPPFLAGS}"
+    export CGO_CFLAGS="${CFLAGS}"
+    export CGO_CXXFLAGS="${CXXFLAGS}"
+    export CGO_LDFLAGS="${LDFLAGS}"
+    export GOPATH="${srcdir}/go"
+    export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+    go build -o lcg
+}
+
+check() {
+  cd "${_pkgname}"
+  go test ./...
+}
+
+package() {
+    cd "${_pkgname}"
+    install -Dm755 "lcg" "${pkgdir}/usr/bin/lcg"
+    install -Dm755 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+

+ 15 - 0
linux-command-gpt/.SRCINFO

@@ -0,0 +1,15 @@
+pkgbase = linux-command-gpt
+	pkgdesc = Get Linux commands in natural language with the power of ChatGPT
+	pkgver = 0.1.2
+	pkgrel = 6
+	url = https://github.com/asrul10/linux-command-gpt
+	arch = x86_64
+	arch = aarch64
+	license = MIT
+	makedepends = go
+	depends = glibc
+	conflicts = linux-command-gpt-git
+	source = git+https://github.com/asrul10/linux-command-gpt#tag=v0.1.2
+	sha256sums = SKIP
+
+pkgname = linux-command-gpt

+ 6 - 0
linux-command-gpt/.gitignore

@@ -0,0 +1,6 @@
+pkg/
+src/
+linux-command-gpt/
+
+*.pkg.*
+*.tar.*

+ 39 - 0
linux-command-gpt/PKGBUILD

@@ -0,0 +1,39 @@
+# Maintainer: Adrian Lopez <zeioth@hotmail.com>
+# Maintainer: txtsd <aur.archlinux@ihavea.quest>
+
+pkgname=linux-command-gpt
+pkgver=0.1.2
+pkgrel=6
+pkgdesc='Get Linux commands in natural language with the power of ChatGPT'
+arch=('x86_64' 'aarch64')
+url='https://github.com/asrul10/linux-command-gpt'
+license=('MIT')
+depends=('glibc')
+makedepends=('go')
+conflicts=('linux-command-gpt-git')
+source=("git+${url}#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+    cd "${pkgname}"
+    # https://wiki.archlinux.org/index.php/Go_package_guidelines
+    export CGO_CPPFLAGS="${CPPFLAGS}"
+    export CGO_CFLAGS="${CFLAGS}"
+    export CGO_CXXFLAGS="${CXXFLAGS}"
+    export CGO_LDFLAGS="${LDFLAGS}"
+    export GOPATH="${srcdir}/go"
+    export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+    go build -o lcg
+}
+
+check() {
+  cd "${pkgname}"
+  go test ./...
+}
+
+package() {
+    cd "${pkgname}"
+    install -Dm755 "lcg" "${pkgdir}/usr/bin/lcg"
+    install -Dm755 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+