openssh.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849
  1. %global ver 8.5p1
  2. %global rel 1%{?dist}
  3. # OpenSSH privilege separation requires a user & group ID
  4. %global sshd_uid 74
  5. %global sshd_gid 74
  6. # Version of ssh-askpass
  7. %global aversion 1.2.4.1
  8. # Do we want to disable building of x11-askpass? (1=yes 0=no)
  9. %global no_x11_askpass 0
  10. # Do we want to disable building of gnome-askpass? (1=yes 0=no)
  11. %global no_gnome_askpass 0
  12. # Do we want to link against a static libcrypto? (1=yes 0=no)
  13. %global static_libcrypto 0
  14. # Do we want smartcard support (1=yes 0=no)
  15. %global scard 0
  16. # Use GTK2 instead of GNOME in gnome-ssh-askpass
  17. %global gtk2 1
  18. # Use build6x options for older RHEL builds
  19. # RHEL 7 not yet supported
  20. %if 0%{?rhel} > 6
  21. %global build6x 0
  22. %else
  23. %global build6x 1
  24. %endif
  25. %if 0%{?fedora} >= 26
  26. %global compat_openssl 1
  27. %else
  28. %global compat_openssl 0
  29. %endif
  30. # Do we want kerberos5 support (1=yes 0=no)
  31. %global kerberos5 1
  32. # Reserve options to override askpass settings with:
  33. # rpm -ba|--rebuild --define 'skip_xxx 1'
  34. %{?skip_x11_askpass:%global no_x11_askpass 1}
  35. %{?skip_gnome_askpass:%global no_gnome_askpass 1}
  36. # Add option to build without GTK2 for older platforms with only GTK+.
  37. # RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
  38. # rpm -ba|--rebuild --define 'no_gtk2 1'
  39. %{?no_gtk2:%global gtk2 0}
  40. # Is this a build for RHL 6.x or earlier?
  41. %{?build_6x:%global build6x 1}
  42. # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
  43. %if %{build6x}
  44. %global _sysconfdir /etc
  45. %endif
  46. # Options for static OpenSSL link:
  47. # rpm -ba|--rebuild --define "static_openssl 1"
  48. %{?static_openssl:%global static_libcrypto 1}
  49. # Options for Smartcard support: (needs libsectok and openssl-engine)
  50. # rpm -ba|--rebuild --define "smartcard 1"
  51. %{?smartcard:%global scard 1}
  52. # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
  53. %global rescue 0
  54. %{?build_rescue:%global rescue 1}
  55. # Turn off some stuff for resuce builds
  56. %if %{rescue}
  57. %global kerberos5 0
  58. %endif
  59. Summary: The OpenSSH implementation of SSH protocol version 2.
  60. Name: openssh
  61. Version: %{ver}
  62. %if %{rescue}
  63. Release: %{rel}rescue
  64. %else
  65. Release: %{rel}
  66. %endif
  67. URL: https://www.openssh.com/portable.html
  68. Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
  69. Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
  70. License: BSD
  71. Group: Applications/Internet
  72. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  73. Obsoletes: ssh
  74. %if %{build6x}
  75. PreReq: initscripts >= 5.00
  76. %else
  77. Requires: initscripts >= 5.20
  78. %endif
  79. BuildRequires: perl
  80. %if %{compat_openssl}
  81. BuildRequires: compat-openssl10-devel
  82. %else
  83. BuildRequires: openssl-devel >= 1.0.1
  84. BuildRequires: openssl-devel < 1.1
  85. %endif
  86. BuildRequires: /bin/login
  87. %if ! %{build6x}
  88. BuildRequires: glibc-devel, pam
  89. %else
  90. BuildRequires: /usr/include/security/pam_appl.h
  91. %endif
  92. %if ! %{no_x11_askpass}
  93. BuildRequires: /usr/include/X11/Xlib.h
  94. # Xt development tools
  95. BuildRequires: libXt-devel
  96. # Provides xmkmf
  97. BuildRequires: imake
  98. # Rely on relatively recent gtk
  99. BuildRequires: gtk2-devel
  100. %endif
  101. %if ! %{no_gnome_askpass}
  102. BuildRequires: pkgconfig
  103. %endif
  104. %if %{kerberos5}
  105. BuildRequires: krb5-devel
  106. BuildRequires: krb5-libs
  107. %endif
  108. %package clients
  109. Summary: OpenSSH clients.
  110. Requires: openssh = %{version}-%{release}
  111. Group: Applications/Internet
  112. Obsoletes: ssh-clients
  113. %package server
  114. Summary: The OpenSSH server daemon.
  115. Group: System Environment/Daemons
  116. Obsoletes: ssh-server
  117. Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
  118. %if ! %{build6x}
  119. Requires: /etc/pam.d/system-auth
  120. %endif
  121. %package askpass
  122. Summary: A passphrase dialog for OpenSSH and X.
  123. Group: Applications/Internet
  124. Requires: openssh = %{version}-%{release}
  125. Obsoletes: ssh-extras
  126. %package askpass-gnome
  127. Summary: A passphrase dialog for OpenSSH, X, and GNOME.
  128. Group: Applications/Internet
  129. Requires: openssh = %{version}-%{release}
  130. Obsoletes: ssh-extras
  131. %description
  132. SSH (Secure SHell) is a program for logging into and executing
  133. commands on a remote machine. SSH is intended to replace rlogin and
  134. rsh, and to provide secure encrypted communications between two
  135. untrusted hosts over an insecure network. X11 connections and
  136. arbitrary TCP/IP ports can also be forwarded over the secure channel.
  137. OpenSSH is OpenBSD's version of the last free version of SSH, bringing
  138. it up to date in terms of security and features, as well as removing
  139. all patented algorithms to separate libraries.
  140. This package includes the core files necessary for both the OpenSSH
  141. client and server. To make this package useful, you should also
  142. install openssh-clients, openssh-server, or both.
  143. %description clients
  144. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  145. into and executing commands on a remote machine. This package includes
  146. the clients necessary to make encrypted connections to SSH servers.
  147. You'll also need to install the openssh package on OpenSSH clients.
  148. %description server
  149. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  150. into and executing commands on a remote machine. This package contains
  151. the secure shell daemon (sshd). The sshd daemon allows SSH clients to
  152. securely connect to your SSH server. You also need to have the openssh
  153. package installed.
  154. %description askpass
  155. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  156. into and executing commands on a remote machine. This package contains
  157. an X11 passphrase dialog for OpenSSH.
  158. %description askpass-gnome
  159. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  160. into and executing commands on a remote machine. This package contains
  161. an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
  162. environment.
  163. %prep
  164. %if ! %{no_x11_askpass}
  165. %setup -q -a 1
  166. %else
  167. %setup -q
  168. %endif
  169. %build
  170. %if %{rescue}
  171. CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
  172. %endif
  173. %configure \
  174. --sysconfdir=%{_sysconfdir}/ssh \
  175. --libexecdir=%{_libexecdir}/openssh \
  176. --datadir=%{_datadir}/openssh \
  177. --with-default-path=/usr/local/bin:/bin:/usr/bin \
  178. --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
  179. --with-privsep-path=%{_var}/empty/sshd \
  180. --with-md5-passwords \
  181. --mandir=%{_mandir} \
  182. --with-mantype=man \
  183. --disable-strip \
  184. %if %{scard}
  185. --with-smartcard \
  186. %endif
  187. %if %{rescue}
  188. --without-pam \
  189. %else
  190. --with-pam \
  191. %endif
  192. %if %{kerberos5}
  193. --with-kerberos5=$K5DIR \
  194. %endif
  195. %if %{static_libcrypto}
  196. perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
  197. %endif
  198. make
  199. %if ! %{no_x11_askpass}
  200. pushd x11-ssh-askpass-%{aversion}
  201. %configure --libexecdir=%{_libexecdir}/openssh
  202. xmkmf -a
  203. make
  204. popd
  205. %endif
  206. # Define a variable to toggle gnome1/gtk2 building. This is necessary
  207. # because RPM doesn't handle nested %if statements.
  208. %if %{gtk2}
  209. gtk2=yes
  210. %else
  211. gtk2=no
  212. %endif
  213. %if ! %{no_gnome_askpass}
  214. pushd contrib
  215. if [ $gtk2 = yes ] ; then
  216. make gnome-ssh-askpass2
  217. mv gnome-ssh-askpass2 gnome-ssh-askpass
  218. else
  219. make gnome-ssh-askpass1
  220. mv gnome-ssh-askpass1 gnome-ssh-askpass
  221. fi
  222. popd
  223. %endif
  224. %install
  225. rm -rf $RPM_BUILD_ROOT
  226. mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
  227. mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
  228. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
  229. make install DESTDIR=$RPM_BUILD_ROOT
  230. install -d $RPM_BUILD_ROOT/etc/pam.d/
  231. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  232. install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
  233. %if %{build6x}
  234. install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
  235. %else
  236. install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
  237. %endif
  238. install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
  239. %if ! %{no_x11_askpass}
  240. install x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
  241. ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
  242. %endif
  243. %if ! %{no_gnome_askpass}
  244. install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
  245. %endif
  246. %if ! %{scard}
  247. rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
  248. %endif
  249. %if ! %{no_gnome_askpass}
  250. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  251. install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  252. install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  253. %endif
  254. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
  255. %clean
  256. rm -rf $RPM_BUILD_ROOT
  257. %triggerun server -- ssh-server
  258. if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
  259. touch /var/run/sshd.restart
  260. fi
  261. %triggerun server -- openssh-server < 2.5.0p1
  262. # Count the number of HostKey and HostDsaKey statements we have.
  263. gawk 'BEGIN {IGNORECASE=1}
  264. /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
  265. END {exit sawhostkey}' /etc/ssh/sshd_config
  266. # And if we only found one, we know the client was relying on the old default
  267. # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
  268. # specified. Now that HostKey is used for both SSH1 and SSH2 keys, specifying
  269. # one nullifies the default, which would have loaded both.
  270. if [ $? -eq 1 ] ; then
  271. echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
  272. echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
  273. fi
  274. %triggerpostun server -- ssh-server
  275. if [ "$1" != 0 ] ; then
  276. /sbin/chkconfig --add sshd
  277. if test -f /var/run/sshd.restart ; then
  278. rm -f /var/run/sshd.restart
  279. /sbin/service sshd start > /dev/null 2>&1 || :
  280. fi
  281. fi
  282. %pre server
  283. %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
  284. %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
  285. -g sshd -M -r sshd 2>/dev/null || :
  286. %post server
  287. /sbin/chkconfig --add sshd
  288. %postun server
  289. /sbin/service sshd condrestart > /dev/null 2>&1 || :
  290. %preun server
  291. if [ "$1" = 0 ]
  292. then
  293. /sbin/service sshd stop > /dev/null 2>&1 || :
  294. /sbin/chkconfig --del sshd
  295. fi
  296. %files
  297. %defattr(-,root,root)
  298. %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
  299. %attr(0755,root,root) %{_bindir}/scp
  300. %attr(0644,root,root) %{_mandir}/man1/scp.1*
  301. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  302. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
  303. %if ! %{rescue}
  304. %attr(0755,root,root) %{_bindir}/ssh-keygen
  305. %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
  306. %attr(0755,root,root) %dir %{_libexecdir}/openssh
  307. %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
  308. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
  309. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
  310. %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
  311. %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
  312. %attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
  313. %endif
  314. %if %{scard}
  315. %attr(0755,root,root) %dir %{_datadir}/openssh
  316. %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
  317. %endif
  318. %files clients
  319. %defattr(-,root,root)
  320. %attr(0755,root,root) %{_bindir}/ssh
  321. %attr(0644,root,root) %{_mandir}/man1/ssh.1*
  322. %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
  323. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
  324. %if ! %{rescue}
  325. %attr(2755,root,nobody) %{_bindir}/ssh-agent
  326. %attr(0755,root,root) %{_bindir}/ssh-add
  327. %attr(0755,root,root) %{_bindir}/ssh-keyscan
  328. %attr(0755,root,root) %{_bindir}/sftp
  329. %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
  330. %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
  331. %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
  332. %attr(0644,root,root) %{_mandir}/man1/sftp.1*
  333. %endif
  334. %if ! %{rescue}
  335. %files server
  336. %defattr(-,root,root)
  337. %dir %attr(0111,root,root) %{_var}/empty/sshd
  338. %attr(0755,root,root) %{_sbindir}/sshd
  339. %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
  340. %attr(0644,root,root) %{_mandir}/man8/sshd.8*
  341. %attr(0644,root,root) %{_mandir}/man5/moduli.5*
  342. %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
  343. %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
  344. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  345. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
  346. %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
  347. %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
  348. %endif
  349. %if ! %{no_x11_askpass}
  350. %files askpass
  351. %defattr(-,root,root)
  352. %doc x11-ssh-askpass-%{aversion}/README
  353. %doc x11-ssh-askpass-%{aversion}/ChangeLog
  354. %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
  355. %{_libexecdir}/openssh/ssh-askpass
  356. %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
  357. %endif
  358. %if ! %{no_gnome_askpass}
  359. %files askpass-gnome
  360. %defattr(-,root,root)
  361. %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
  362. %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
  363. %endif
  364. %changelog
  365. * Mon Jul 20 2020 Damien Miller <djm@mindrto.org>
  366. - Add ssh-sk-helper and corresponding manual page.
  367. * Sat Feb 10 2018 Darren Tucker <dtucker@dtucker.net>
  368. - Update openssl-devel dependency to match current requirements.
  369. - Handle Fedora >=6 openssl 1.0 compat libs.
  370. - Remove SSH1 from description.
  371. - Don't strip binaries at build time so that debuginfo package can be
  372. created.
  373. * Sun Nov 16 2014 Nico Kadel-Garcia <nakdel@gmail.com>
  374. - Add '--mandir' and '--with-mantype' for RHEL 5 compatibility
  375. - Add 'dist' option to 'ver' so package names reflect OS at build time
  376. - Always include x11-ssh-askpass tarball in SRPM
  377. - Add openssh-x11-aspass BuildRequires for libXT-devel, imake, gtk2-devel
  378. - Discard 'K5DIR' reporting, not usable inside 'mock' for RHEL 5 compatibility
  379. - Discard obsolete '--with-rsh' configure option
  380. - Update openssl-devel dependency to 0.9.8f, as found in autoconf
  381. * Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
  382. - test for skip_x11_askpass (line 77) should have been for no_x11_askpass
  383. * Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
  384. - Remove noip6 option. This may be controlled at run-time in client config
  385. file using new AddressFamily directive
  386. * Mon May 12 2003 Damien Miller <djm@mindrot.org>
  387. - Don't install profile.d scripts when not building with GNOME/GTK askpass
  388. (patch from bet@rahul.net)
  389. * Tue Oct 01 2002 Damien Miller <djm@mindrot.org>
  390. - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
  391. * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
  392. - Use contrib/ Makefile for building askpass programs
  393. * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
  394. - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
  395. - Add new {ssh,sshd}_config.5 manpages
  396. - Add new ssh-keysign program and remove setuid from ssh client
  397. * Fri May 10 2002 Damien Miller <djm@mindrot.org>
  398. - Merge in spec changes from RedHat, reorgansie a little
  399. - Add Privsep user, group and directory
  400. * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
  401. - bump and grind (through the build system)
  402. * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
  403. - require sharutils for building (mindrot #137)
  404. - require db1-devel only when building for 6.x (#55105), which probably won't
  405. work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
  406. - require pam-devel by file (not by package name) again
  407. - add Markus's patch to compile with OpenSSL 0.9.5a (from
  408. http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
  409. building for 6.x
  410. * Thu Mar 7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
  411. - update to 3.1p1
  412. * Tue Mar 5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
  413. - update to SNAP-20020305
  414. - drop debug patch, fixed upstream
  415. * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
  416. - update to SNAP-20020220 for testing purposes (you've been warned, if there's
  417. anything to be warned about, gss patches won't apply, I don't mind)
  418. * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
  419. - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
  420. exchange, authentication, and named key support
  421. * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
  422. - remove dependency on db1-devel, which has just been swallowed up whole
  423. by gnome-libs-devel
  424. * Sat Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  425. - adjust build dependencies so that build6x actually works right (fix
  426. from Hugo van der Kooij)
  427. * Tue Dec 4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
  428. - update to 3.0.2p1
  429. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
  430. - update to 3.0.1p1
  431. * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  432. - update to current CVS (not for use in distribution)
  433. * Thu Nov 8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
  434. - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
  435. 3.0p1 spec file and init script
  436. * Wed Nov 7 2001 Nalin Dahyabhai <nalin@redhat.com>
  437. - update to 3.0p1
  438. - update to x11-ssh-askpass 1.2.4.1
  439. - change build dependency on a file from pam-devel to the pam-devel package
  440. - replace primes with moduli
  441. * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
  442. - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
  443. * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
  444. - Merge changes to rescue build from current sysadmin survival cd
  445. * Thu Sep 6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
  446. - fix scp's server's reporting of file sizes, and build with the proper
  447. preprocessor define to get large-file capable open(), stat(), etc.
  448. (sftp has been doing this correctly all along) (#51827)
  449. - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
  450. - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
  451. - mark profile.d scriptlets as config files (#42337)
  452. - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
  453. - change a couple of log() statements to debug() statements (#50751)
  454. - pull cvs patch to add -t flag to sshd (#28611)
  455. - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
  456. * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
  457. - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
  458. * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  459. - pull cvs patch to fix remote port forwarding with protocol 2
  460. * Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com>
  461. - pull cvs patch to add session initialization to no-pty sessions
  462. - pull cvs patch to not cut off challengeresponse auth needlessly
  463. - refuse to do X11 forwarding if xauth isn't there, handy if you enable
  464. it by default on a system that doesn't have X installed (#49263)
  465. * Wed Aug 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  466. - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
  467. * Mon Aug 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  468. - pass OPTIONS correctly to initlog (#50151)
  469. * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  470. - switch to x11-ssh-askpass 1.2.2
  471. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  472. - rebuild in new environment
  473. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  474. - disable the gssapi patch
  475. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  476. - update to 2.9p2
  477. - refresh to a new version of the gssapi patch
  478. * Thu Jun 7 2001 Nalin Dahyabhai <nalin@redhat.com>
  479. - change Copyright: BSD to License: BSD
  480. - add Markus Friedl's unverified patch for the cookie file deletion problem
  481. so that we can verify it
  482. - drop patch to check if xauth is present (was folded into cookie patch)
  483. - don't apply gssapi patches for the errata candidate
  484. - clear supplemental groups list at startup
  485. * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  486. - fix an error parsing the new default sshd_config
  487. - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
  488. dealing with comments right
  489. * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  490. - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
  491. to be removed before the next beta cycle because it's a big departure
  492. from the upstream version
  493. * Thu May 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  494. - finish marking strings in the init script for translation
  495. - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
  496. at startup (change merged from openssh.com init script, originally by
  497. Pekka Savola)
  498. - refuse to do X11 forwarding if xauth isn't there, handy if you enable
  499. it by default on a system that doesn't have X installed
  500. * Wed May 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  501. - update to 2.9
  502. - drop various patches that came from or went upstream or to or from CVS
  503. * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  504. - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
  505. * Sun Apr 8 2001 Preston Brown <pbrown@redhat.com>
  506. - remove explicit openssl requirement, fixes builddistro issue
  507. - make initscript stop() function wait until sshd really dead to avoid
  508. races in condrestart
  509. * Mon Apr 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  510. - mention that challengereponse supports PAM, so disabling password doesn't
  511. limit users to pubkey and rsa auth (#34378)
  512. - bypass the daemon() function in the init script and call initlog directly,
  513. because daemon() won't start a daemon it detects is already running (like
  514. open connections)
  515. - require the version of openssl we had when we were built
  516. * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  517. - make do_pam_setcred() smart enough to know when to establish creds and
  518. when to reinitialize them
  519. - add in a couple of other fixes from Damien for inclusion in the errata
  520. * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
  521. - update to 2.5.2p2
  522. - call setcred() again after initgroups, because the "creds" could actually
  523. be group memberships
  524. * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  525. - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
  526. - don't enable challenge-response by default until we find a way to not
  527. have too many userauth requests (we may make up to six pubkey and up to
  528. three password attempts as it is)
  529. - remove build dependency on rsh to match openssh.com's packages more closely
  530. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  531. - remove dependency on openssl -- would need to be too precise
  532. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  533. - rebuild in new environment
  534. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  535. - Revert the patch to move pam_open_session.
  536. - Init script and spec file changes from Pekka Savola. (#28750)
  537. - Patch sftp to recognize '-o protocol' arguments. (#29540)
  538. * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
  539. - Chuck the closing patch.
  540. - Add a trigger to add host keys for protocol 2 to the config file, now that
  541. configuration file syntax requires us to specify it with HostKey if we
  542. specify any other HostKey values, which we do.
  543. * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  544. - Redo patch to move pam_open_session after the server setuid()s to the user.
  545. - Rework the nopam patch to use be picked up by autoconf.
  546. * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
  547. - Update for 2.5.1p1.
  548. - Add init script mods from Pekka Savola.
  549. - Tweak the init script to match the CVS contrib script more closely.
  550. - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
  551. adding id_rsa.
  552. * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  553. - Update for 2.5.0p1.
  554. - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
  555. - Resync with parts of Damien Miller's openssh.spec from CVS, including
  556. update of x11 askpass to 1.2.0.
  557. - Only require openssl (don't prereq) because we generate keys in the init
  558. script now.
  559. * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  560. - Don't open a PAM session until we've forked and become the user (#25690).
  561. - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
  562. host the user is attempting a login from.
  563. - Resync with parts of Damien Miller's openssh.spec from CVS.
  564. - Don't expose KbdInt responses in debug messages (from CVS).
  565. - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
  566. * Wed Feb 7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
  567. - i18n-tweak to initscript.
  568. * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  569. - More gettextizing.
  570. - Close all files after going into daemon mode (needs more testing).
  571. - Extract patch from CVS to handle auth banners (in the client).
  572. - Extract patch from CVS to handle compat weirdness.
  573. * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
  574. - Finish with the gettextizing.
  575. * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  576. - Fix a bug in auth2-pam.c (#23877)
  577. - Gettextize the init script.
  578. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  579. - Incorporate a switch for using PAM configs for 6.x, just in case.
  580. * Tue Dec 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  581. - Incorporate Bero's changes for a build specifically for rescue CDs.
  582. * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  583. - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
  584. succeeded, to allow public-key authentication after a failure with "none"
  585. authentication. (#21268)
  586. * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  587. - Update to x11-askpass 1.1.1. (#21301)
  588. - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
  589. * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
  590. - Merge multiple PAM text messages into subsequent prompts when possible when
  591. doing keyboard-interactive authentication.
  592. * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
  593. - Disable the built-in MD5 password support. We're using PAM.
  594. - Take a crack at doing keyboard-interactive authentication with PAM, and
  595. enable use of it in the default client configuration so that the client
  596. will try it when the server disallows password authentication.
  597. - Build with debugging flags. Build root policies strip all binaries anyway.
  598. * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  599. - Use DESTDIR instead of %%makeinstall.
  600. - Remove /usr/X11R6/bin from the path-fixing patch.
  601. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  602. - Add the primes file from the latest snapshot to the main package (#20884).
  603. - Add the dev package to the prereq list (#19984).
  604. - Remove the default path and mimic login's behavior in the server itself.
  605. * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  606. - Resync with conditional options in Damien Miller's .spec file for an errata.
  607. - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
  608. * Tue Nov 7 2000 Nalin Dahyabhai <nalin@redhat.com>
  609. - Update to OpenSSH 2.3.0p1.
  610. - Update to x11-askpass 1.1.0.
  611. - Enable keyboard-interactive authentication.
  612. * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  613. - Update to ssh-askpass-x11 1.0.3.
  614. - Change authentication related messages to be private (#19966).
  615. * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
  616. - Patch ssh-keygen to be able to list signatures for DSA public key files
  617. it generates.
  618. * Thu Oct 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  619. - Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
  620. build PAM authentication in.
  621. - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
  622. - Clean out no-longer-used patches.
  623. - Patch ssh-add to try to add both identity and id_dsa, and to error only
  624. when neither exists.
  625. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  626. - Update x11-askpass to 1.0.2. (#17835)
  627. - Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
  628. always find them in the right place. (#17909)
  629. - Set the default path to be the same as the one supplied by /bin/login, but
  630. add /usr/X11R6/bin. (#17909)
  631. - Try to handle obsoletion of ssh-server more cleanly. Package names
  632. are different, but init script name isn't. (#17865)
  633. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  634. - Update to 2.2.0p1. (#17835)
  635. - Tweak the init script to allow proper restarting. (#18023)
  636. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  637. - Update to 20000823 snapshot.
  638. - Change subpackage requirements from %%{version} to %%{version}-%%{release}
  639. - Back out the pipe patch.
  640. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  641. - Update to 2.1.1p4, which includes fixes for config file parsing problems.
  642. - Move the init script back.
  643. - Add Damien's quick fix for wackiness.
  644. * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  645. - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
  646. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  647. - Move condrestart to server postun.
  648. - Move key generation to init script.
  649. - Actually use the right patch for moving the key generation to the init script.
  650. - Clean up the init script a bit.
  651. * Wed Jul 5 2000 Nalin Dahyabhai <nalin@redhat.com>
  652. - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
  653. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  654. - Update to 2.1.1p2.
  655. - Use of strtok() considered harmful.
  656. * Sat Jul 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  657. - Get the build root out of the man pages.
  658. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  659. - Add and use condrestart support in the init script.
  660. - Add newer initscripts as a prereq.
  661. * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
  662. - Build in new environment (release 2)
  663. - Move -clients subpackage to Applications/Internet group
  664. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  665. - Update to 2.2.1p1
  666. * Sat Jun 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  667. - Patch to build with neither RSA nor RSAref.
  668. - Miscellaneous FHS-compliance tweaks.
  669. - Fix for possibly-compressed man pages.
  670. * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
  671. - Updated for new location
  672. - Updated for new gnome-ssh-askpass build
  673. * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
  674. - Added Jim Knoble's <jmknoble@pobox.com> askpass
  675. * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
  676. - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
  677. * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
  678. - Added 'Obsoletes' directives
  679. * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
  680. - Use make install
  681. - Subpackages
  682. * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
  683. - Added links for slogin
  684. - Fixed perms on manpages
  685. * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
  686. - Renamed init script
  687. * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
  688. - Back to old binary names
  689. * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
  690. - Use autoconf
  691. - New binary names
  692. * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
  693. - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.