control 1.7 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. Source: duma
  2. Section: devel
  3. Priority: optional
  4. Maintainer: Debian QA Group <packages@qa.debian.org>
  5. Build-Depends:
  6. debhelper-compat (= 12),
  7. Standards-Version: 3.8.1
  8. Homepage: https://github.com/johnsonjh/duma
  9. Vcs-Browser: https://github.com/johnsonjh/duma
  10. Vcs-Git: https://github.com/johnsonjh/duma.git
  11. Package: duma
  12. Architecture: any
  13. Depends: ${shlibs:Depends}, ${misc:Depends}
  14. Description: library to detect buffer overruns and under-runs in C and C++ programs
  15. Open-source library to detect buffer overruns and under-runs
  16. in C and C++ programs.
  17. .
  18. This library is a fork of Bruce Perens Electric Fence library and adds
  19. some new features to it. Features of the DUMA library:
  20. * "overloads" all standard memory allocation functions like
  21. malloc(), calloc(), memalign(), strdup(), operator new, operator
  22. new[] and also their counterpart deallocation functions like free(),
  23. operator delete and operator delete[]
  24. * utilizes the MMU (memory management unit) of the CPU:
  25. allocates and protects an extra memory page to detect any illegal
  26. access beyond the top of the buffer (or bottom, at the user's option)
  27. * stops the program at exactly that instruction, which does the
  28. erroneous access to the protected memory page,
  29. allowing location of the defective source code in a debugger
  30. detects erroneous writes at the non-protected end of the memory
  31. block at deallocation of the memory block
  32. * detects mismatch of allocation/deallocation functions: f.e.
  33. allocation with malloc() but deallocation with operator delete
  34. * leak detection: detect memory blocks which were not deallocated
  35. until program exit
  36. * preloading of the library
  37. * allowing tests without necessity of changing source code or recompilation