0001-Fix-spelling-mistakes.patch 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. From 781ed34bee122a9c56fe776420d963be454c94fc Mon Sep 17 00:00:00 2001
  2. From: Peter Spiess-Knafl <peter.knafl@gmail.com>
  3. Date: Tue, 16 Aug 2016 09:32:26 +0200
  4. Subject: [PATCH] Fix spelling mistakes
  5. ---
  6. src/jsonrpccpp/client/connectors/unixdomainsocketclient.cpp | 2 +-
  7. src/jsonrpccpp/common/specificationparser.cpp | 2 +-
  8. src/jsonrpccpp/server/connectors/httpserver.cpp | 2 +-
  9. 3 files changed, 3 insertions(+), 3 deletions(-)
  10. diff --git a/src/jsonrpccpp/client/connectors/unixdomainsocketclient.cpp b/src/jsonrpccpp/client/connectors/unixdomainsocketclient.cpp
  11. index 585e88d..160ef1b 100644
  12. --- a/src/jsonrpccpp/client/connectors/unixdomainsocketclient.cpp
  13. +++ b/src/jsonrpccpp/client/connectors/unixdomainsocketclient.cpp
  14. @@ -44,7 +44,7 @@ void UnixDomainSocketClient::SendRPCMessage(const std::string& message, std::str
  15. socket_fd = socket(AF_UNIX, SOCK_STREAM, 0);
  16. if (socket_fd < 0)
  17. {
  18. - throw JsonRpcException(Errors::ERROR_CLIENT_CONNECTOR, "Could not created unix domain socket");
  19. + throw JsonRpcException(Errors::ERROR_CLIENT_CONNECTOR, "Could not create unix domain socket");
  20. }
  21. memset(&address, 0, sizeof(sockaddr_un));
  22. diff --git a/src/jsonrpccpp/common/specificationparser.cpp b/src/jsonrpccpp/common/specificationparser.cpp
  23. index e900431..29890b7 100644
  24. --- a/src/jsonrpccpp/common/specificationparser.cpp
  25. +++ b/src/jsonrpccpp/common/specificationparser.cpp
  26. @@ -44,7 +44,7 @@ vector<Procedure> SpecificationParser::GetProceduresFromString(const string &c
  27. GetProcedure(val[i], proc);
  28. if (procnames.find(proc.GetProcedureName()) != procnames.end())
  29. {
  30. - throw JsonRpcException(Errors::ERROR_SERVER_PROCEDURE_SPECIFICATION_SYNTAX, "Procedurename not uniqe: " + proc.GetProcedureName());
  31. + throw JsonRpcException(Errors::ERROR_SERVER_PROCEDURE_SPECIFICATION_SYNTAX, "Procedurename not unique: " + proc.GetProcedureName());
  32. }
  33. procnames[proc.GetProcedureName()] = proc;
  34. result.push_back(proc);
  35. diff --git a/src/jsonrpccpp/server/connectors/httpserver.cpp b/src/jsonrpccpp/server/connectors/httpserver.cpp
  36. index 5ec15a2..40d3c5e 100644
  37. --- a/src/jsonrpccpp/server/connectors/httpserver.cpp
  38. +++ b/src/jsonrpccpp/server/connectors/httpserver.cpp
  39. @@ -147,7 +147,7 @@ int HttpServer::callback(void *cls, MHD_Connection *connection, const char *url,
  40. if (handler == NULL)
  41. {
  42. client_connection->code = MHD_HTTP_INTERNAL_SERVER_ERROR;
  43. - client_connection->server->SendResponse("No client conneciton handler found", client_connection);
  44. + client_connection->server->SendResponse("No client connection handler found", client_connection);
  45. }
  46. else
  47. {
  48. --
  49. 2.8.1