rules 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Sample debian/rules that uses debhelper.
  4. # This file was originally written by Joey Hess and Craig Small.
  5. # As a special exception, when this file is copied by dh-make into a
  6. # dh-make output file, you may use that output file without restriction.
  7. # This special exception was added by Craig Small in version 0.37 of dh-make.
  8. # Uncomment this to turn on verbose mode.
  9. #export DH_VERBOSE=1
  10. configure: configure-stamp
  11. configure-stamp:
  12. dh_testdir
  13. # qmake PREFIX=/usr# Uncomment this line for use without Qt Creator
  14. touch configure-stamp
  15. build: build-stamp
  16. build-stamp: configure-stamp
  17. dh_testdir
  18. # Add here commands to compile the package.
  19. # $(MAKE) # Uncomment this line for use without Qt Creator
  20. #docbook-to-man debian/imquery.sgml > imquery.1
  21. touch $@
  22. clean:
  23. dh_testdir
  24. dh_testroot
  25. rm -f build-stamp configure-stamp
  26. # Add here commands to clean up after the build process.
  27. $(MAKE) clean
  28. dh_clean
  29. install: build
  30. dh_testdir
  31. dh_testroot
  32. dh_clean -k
  33. dh_installdirs
  34. # Add here commands to install the package into debian/imquery.
  35. $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/imquery install
  36. sed 's:^Icon=.*:Icon=/usr/share/icons/hicolor/64x64/apps/IMQuery.png:' /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop > /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop.sed || echo -n
  37. mv /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop.sed /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop || echo -n
  38. sed 's:Exec=.*:Exec=/opt/IMQuery/bin/IMQuery:' /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop > /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop.sed || echo -n
  39. mv /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop.sed /C/Users/Amanda/QtProjects/IMQuery/IMQuery/debian/imquery/usr/share/applications/IMQuery.desktop || echo -n
  40. # Build architecture-independent files here.
  41. binary-indep: build install
  42. # We have nothing to do by default.
  43. # Build architecture-dependent files here.
  44. binary-arch: build install
  45. dh_testdir
  46. dh_testroot
  47. dh_installchangelogs
  48. dh_installdocs
  49. dh_installexamples
  50. # dh_install
  51. # dh_installmenu
  52. # dh_installdebconf
  53. # dh_installlogrotate
  54. # dh_installemacsen
  55. # dh_installpam
  56. # dh_installmime
  57. # dh_python
  58. # dh_installinit
  59. # dh_installcron
  60. # dh_installinfo
  61. dh_installman
  62. dh_link
  63. dh_strip
  64. dh_compress
  65. dh_fixperms
  66. # dh_perl
  67. # dh_makeshlibs
  68. dh_installdeb
  69. dh_shlibdeps
  70. dh_gencontrol
  71. dh_md5sums
  72. dh_builddeb
  73. binary: binary-indep binary-arch
  74. .PHONY: build clean binary-indep binary-arch binary install configure