PKGBUILD 1.0 KB

1234567891011121314151617181920212223242526272829303132333435
  1. # Maintainer : Felix Yan <felixonmars@archlinux.org>
  2. # Contributor: speps <speps at aur dot archlinux dot org>
  3. # Contributor: Arnau Sanchez <tokland {at} gmail {dot} com>
  4. pkgname=python-pyquery
  5. pkgver=1.4.3
  6. pkgrel=1
  7. pkgdesc="A jquery-like library for python."
  8. arch=('any')
  9. url="https://github.com/gawel/pyquery/"
  10. license=('Modified-BSD')
  11. depends=('python-lxml' 'python-cssselect')
  12. optdepends=('python-webob: query wsgi app')
  13. makedepends=('python-setuptools')
  14. #checkdepends=('python-requests' 'python-webob' 'python-nose' 'python-webtest')
  15. source=("https://github.com/gawel/pyquery/archive/$pkgver/$pkgname-$pkgver.tar.gz")
  16. sha512sums=('ab5110232d79209fb861fa3ac61c8803352c28c8372ba5d96b3fe731ebdb0b732c0c1642719c9cebbd0030a27edd2a962a7c368c99a7c966bf0ea77f7ae89a37')
  17. build() {
  18. cd pyquery-$pkgver
  19. python setup.py build
  20. }
  21. #check() {
  22. # cd pyquery-$pkgver
  23. # nosetests3
  24. #}
  25. package() {
  26. cd pyquery-$pkgver
  27. python setup.py install -O1 --root="$pkgdir"
  28. install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname/
  29. }