123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109 |
- #!/bin/sh
- #
- # Slackware build script for merecat
- #
- # Copyright (C) 2023-2024 Ricardo García Jiménez <ricardogj08@riseup.net>
- #
- # This program is free software: you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
- # the Free Software Foundation, either version 3 of the License, or
- # (at your option) any later version.
- #
- # This program is distributed in the hope that it will be useful,
- # but WITHOUT ANY WARRANTY; without even the implied warranty of
- # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- # GNU General Public License for more details.
- #
- # You should have received a copy of the GNU General Public License
- # along with this program. If not, see <https://www.gnu.org/licenses/>.
- #
- PRGNAM=merecat
- VERSION=${VERSION:-git}
- SOURCE="https://github.com/troglobit/${PRGNAM}.${VERSION}"
- BUILD=${BUILD:-4}
- TAG=${TAG:-_rgj}
- PKGTYPE=${PKGTYPE:-tgz}
- NUMJOBS=${NUMJOBS:-"$(nproc)"}
- if [ -z "${ARCH}" ]; then
- case "$(uname -m)" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$(uname -m) ;;
- esac
- fi
- CWD=$(pwd)
- TMP=${TMP:-/tmp/build}
- PKG="${TMP}/package-${PRGNAM}"
- OUTPUT=${OUTPUT:-/tmp}
- if [ "${ARCH}" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "${ARCH}" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "${ARCH}" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf "${PKG}"
- mkdir -p "${TMP}" "${PKG}" "${OUTPUT}"
- cd "${TMP}"
- rm -rf "${PRGNAM}"
- git clone "${SOURCE}"
- cd "${PRGNAM}"
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- ./autogen.sh
- CFLAGS="${SLKCFLAGS}" \
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir="/var/${PRGNAM}" \
- --libdir="/usr/lib${LIBDIRSUFFIX}" \
- --mandir=/usr/man \
- --docdir="/usr/doc/${PRGNAM}-${VERSION}" \
- --build="${ARCH}-slackware-linux" \
- --host="${ARCH}-slackware-linux" \
- --enable-htaccess \
- --enable-htpasswd \
- --disable-dirlisting
- make -j"${NUMJOBS}"
- make install DESTDIR="${PKG}"
- find "${PKG}" -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find "${PKG}/usr/man" -type f -exec gzip -9 {} \;
- # Add init script.
- mkdir -p "${PKG}/etc/rc.d"
- cat "${CWD}/rc.${PRGNAM}" > "${PKG}/etc/rc.d/rc.${PRGNAM}.new"
- cat "${CWD}/${PRGNAM}.SlackBuild" > "${PKG}/usr/doc/${PRGNAM}-${VERSION}/${PRGNAM}.SlackBuild"
- mkdir -p "${PKG}/install"
- cat "${CWD}/slack-desc" > "${PKG}/install/slack-desc"
- cat "${CWD}/doinst.sh" > "${PKG}/install/doinst.sh"
- # Backup config file.
- mv "${PKG}/etc/${PRGNAM}.conf" "${PKG}/etc/${PRGNAM}.conf.new"
- cd "${PKG}"
- /sbin/makepkg -l y -c n "${OUTPUT}/${PRGNAM}-${VERSION}-${ARCH}-${BUILD}${TAG}.${PKGTYPE}"
|