rules 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. #!/usr/bin/make -f
  2. # Sample debian/rules that uses debhelper.
  3. # GNU copyright 1997 to 1999 by Joey Hess.
  4. # Uncomment this to turn on verbose mode.
  5. #export DH_VERBOSE=1
  6. # This is the debhelper compatibility version to use.
  7. export DH_COMPAT=3
  8. ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
  9. CFLAGS += -g
  10. endif
  11. ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
  12. INSTALL_PROGRAM += -s
  13. endif
  14. configure: configure-stamp
  15. configure-stamp:
  16. dh_testdir
  17. # Add here commands to configure the package.
  18. touch configure-stamp
  19. build: build-stamp
  20. build-stamp: configure-stamp
  21. dh_testdir
  22. # Add here commands to compile the package.
  23. $(MAKE) build build-doc
  24. #/usr/bin/docbook-to-man debian/mtt.sgml > mtt.1
  25. touch build-stamp
  26. clean:
  27. dh_testdir
  28. dh_testroot
  29. rm -f build-stamp configure-stamp
  30. # Add here commands to clean up after the build process.
  31. -$(MAKE) distclean
  32. dh_clean
  33. install: build
  34. dh_testdir
  35. dh_testroot
  36. dh_clean -k
  37. dh_installdirs
  38. # Add here commands to install the package into debian/mtt.
  39. $(MAKE) install install-doc install-xfig DESTDIR=$(CURDIR)/debian/mtt
  40. # Build architecture-independent files here.
  41. binary-indep: build install
  42. # We have nothing to do by default.
  43. dh_testdir
  44. dh_testroot
  45. # dh_installdebconf
  46. dh_installdocs
  47. dh_installexamples
  48. dh_installmenu
  49. # dh_installlogrotate
  50. # dh_installemacsen
  51. # dh_installpam
  52. # dh_installmime
  53. # dh_installinit
  54. dh_installcron
  55. dh_installman debian/mtt.1
  56. dh_installinfo
  57. # dh_undocumented
  58. dh_installchangelogs
  59. dh_link
  60. dh_strip
  61. dh_compress
  62. dh_fixperms
  63. # dh_makeshlibs
  64. dh_installdeb
  65. # dh_perl
  66. dh_shlibdeps
  67. dh_gencontrol
  68. dh_md5sums
  69. dh_builddeb
  70. # Build architecture-dependent files here.
  71. binary-arch: build install
  72. binary: binary-indep binary-arch
  73. .PHONY: build clean binary-indep binary-arch binary install configure