default.nix 602 B

1234567891011121314151617181920212223242526272829
  1. { pkgs, python3Packages }:
  2. python3Packages.buildPythonApplication rec {
  3. pname = "themechanger";
  4. version = "0.12.0";
  5. format = "other";
  6. src = ./.;
  7. nativeBuildInputs = with pkgs; [
  8. gobject-introspection
  9. meson
  10. ninja
  11. pkg-config
  12. wrapGAppsHook
  13. desktop-file-utils
  14. gtk3
  15. ];
  16. buildInputs = with pkgs; [
  17. glib
  18. gtk3
  19. python3
  20. gsettings-desktop-schemas
  21. ];
  22. propagatedBuildInputs = with python3Packages; [
  23. pygobject3
  24. ];
  25. postPatch = ''
  26. patchShebangs postinstall.py
  27. '';
  28. }