Matías Fonzo bd33736386 qi: minor enhancements 1 year ago
..
doc 75c04d2596 qi: launch our package manager to version 1.3 1 year ago
etc 0184ff51c5 qi: upgrade blacklist to match (current) "perl5" package name 1 year ago
src bd33736386 qi: minor enhancements 1 year ago
AUTHORS 4aba604973 Initial import from the conversion Fossil -> Git 3 years ago
COPYING 4aba604973 Initial import from the conversion Fossil -> Git 3 years ago
CREDITS bb03d7a617 qi: doc: corrections coming from Antonio Diaz Diaz 2 years ago
Makefile 75c04d2596 qi: launch our package manager to version 1.3 1 year ago
NEWS 75c04d2596 qi: launch our package manager to version 1.3 1 year ago
README bb03d7a617 qi: doc: corrections coming from Antonio Diaz Diaz 2 years ago
configure a00da826cf qi: use same paths for packagedir and targetdir than graft, new version 1.0-rc49 2 years ago

README

+-------------+
| Qi's README |
+-------------+


1. Introduction
2. Installation
3. Contact


1. Introduction.

Qi is a simple but well-integrated package manager. It can create,
install, remove, and upgrade software packages. Qi produces binary
packages using recipes, which are files containing specific instructions
to build each package from source. Qi can manage multiple packages
under a single directory hierarchy. This method allows to maintain a
set of packages and multiple versions of them. This means that Qi could
be used as the main package manager or complement the existing one.

Qi offers a friendly command line interface, a global configuration
file, a simple recipe layout to deploy software packages; also works
with binary packages in parallel, speeding up installations and packages
in production. The format used for packages is a simplified but safe
POSIX pax archive compressed with lzip.

Qi is a modern (POSIX-compliant) shell script released under the
terms of the GNU General Public License. There are only two major
dependencies for the magic: graft(1) and tarlz(1), the rest is expected
to be found in any Unix-like system.

2. Installation.

Requirements:

- A POSIX-compliant shell.

- Graft: http://peters.gormand.com.au/Home/tools

Perl (http://www.perl.org) is required in order to run graft(1).

Note
Take into account when graft is installed, you can define some
macros like PACKAGEDIR and TARGETDIR. To be consistent use the
same paths when `configure', adjusting it via --packagedir and
--targetdir options. If you have not changed the default values
used on the graft installation, you can avoid these steps, since
qi uses the same graft values for PACKAGEDIR and TARGETDIR.

- Tarlz: http://lzip.nongnu.org/tarlz.html

- A mktemp(1) implementation (normally included in the system):
http://www.mktemp.org

To configure, make and install qi, type:

$ ./configure
$ make
$ make install

See `./configure --help' for more options.

To install in a different location, DESTDIR is supported. This is useful
for package distributors:

$ make DESTDIR=/tmp/qi install

3. Contact.

The Qi home page can be found at `http://www.dragora.org'.
Send bug reports or suggestions to .