GTL.spec 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. ### BEGIN GTL.spec
  2. # Note that this is NOT a relocatable package
  3. Name: GTL
  4. Summary: The Graph Template Library
  5. Version: 1.0.0
  6. Release: 1
  7. Group: Development/Libraries
  8. Source: http://infosun.fmi.uni-passau.de/GTL/download/GTL-1.0.0.tar.gz
  9. URL: http://infosun.fmi.uni-passau.de/GTL/
  10. Copyright: Copyright (C) 1999 University of Passau
  11. Vendor: University of Passau
  12. Packager: Marcus Raitner <raitner@fmi.uni-passau.de>
  13. Prefix: /usr
  14. BuildRoot: /var/tmp/%{name}-%{version}-root
  15. %description
  16. There are some basic data structures and algorithms that are frequently
  17. used in many programs. This includes container classes such as vectors,
  18. sets and lists.
  19. Many commercial but some free libraries have implemented these data
  20. structures and algorithms in a general way. This makes them usable for
  21. many purposes.
  22. One of these libraries is the Standard Template Library (STL), an
  23. extremely flexible implementation of many container classes and standard
  24. algorithms. STL is supposed to become a part of the C++ standard library
  25. and therefore is an ideal basis when writing portable programs.
  26. Unfortunately, STL has no support for graphs and graph
  27. algorithms. However, graphs are widely used for complex relational
  28. structures.
  29. Since we are intensively working with graph algorithms and Graphlet, we
  30. decided to implement GTL, a graph library based on STL. For the design
  31. of GTL's API the API of LEDA has served as a basis. GTL contains the
  32. classes needed to work with graphs, nodes and edges and some basic
  33. algorithms as building blocks for more complex graph algorithms. Further
  34. algorithms are under work.'
  35. %changelog
  36. * Thu Oct 26 2000 Marcus Raitner <raitner@fmi.uni-passau.de>
  37. - New release
  38. * Tue Mar 07 2000 Marcus Raitner <raitner@fmi.uni-passau.de>
  39. - New release
  40. * Wed Feb 02 2000 Reinhard Katzmann <reinhard@suamor.de>
  41. - Added cleanup section for temporary BuildRoot
  42. - Simplified file section
  43. - Needed to fix GTL.h to use map even with gcc 2.95 :-( (patch file)
  44. - Added Buildroot which was missing and would overwrite old version of GTL while installing
  45. * Fri Nov 26 1999 Marcus Raitner <raitner@fmi.uni-passau.de>
  46. - Initial RPM packaging.
  47. %prep
  48. %setup
  49. #%patch -p0
  50. %build
  51. CXXFLAGS=-O3 CPPFLAGS="" CFLAGS="" ./configure --enable-static --prefix=/usr
  52. make
  53. %install
  54. make prefix=$RPM_BUILD_ROOT%{prefix} install
  55. strip $RPM_BUILD_ROOT%{prefix}/lib/libGTL-1.0.0.so $RPM_BUILD_ROOT%{prefix}/lib/libGTL.a
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. PATH="$PATH:/sbin" ldconfig -n /usr/lib
  60. %files
  61. %doc README
  62. %doc INSTALL
  63. %doc doc/latex/GTL.ps
  64. %doc doc/html
  65. /usr/include/GTL
  66. /usr/lib
  67. ###END GTL.spec