rules 432 B

12345678910111213141516171819202122
  1. #!/usr/bin/make -f
  2. export LC_ALL=C.UTF-8
  3. export DH_VERBOSE=1
  4. export RAZERCFG_PKG_BUILD=1
  5. override_dh_auto_configure:
  6. dh_auto_configure -- -DLIBRAZER_SHARED=OFF
  7. override_dh_clean:
  8. dh_clean
  9. rm -rf ui/build ui/pyrazer/__pycache__ ui/setup.py
  10. override_dh_install:
  11. dh_install --fail-missing --exclude=librazer.a
  12. override_dh_installinit:
  13. dh_installinit --name=razerd
  14. %:
  15. dh $@ --with systemd --with python3 --buildsystem=cmake